summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD31
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5d3aee312781
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = python2-mne-git
+ pkgdesc = Open-source Python software for exploring, visualizing, and analyzing human neurophysiological data: MEG, EEG, sEEG, ECoG, and more.
+ pkgver = 0.2.r13098.g05a09f7e5
+ pkgrel = 2
+ url = https://www.martinos.org/mne/stable/index.html
+ arch = any
+ license = BSD
+ makedepends = git
+ depends = python2>=2.7
+ depends = python2-numpy>=1.8
+ depends = python2-scipy>=0.12
+ optdepends = python2-matplotlib
+ optdepends = mayavi
+ optdepends = python2-scikit-learn
+ optdepends = python2-nibabel
+ optdepends = python2-pandas
+ optdepends = picard
+ provides = python2-mne
+ conflicts = python2-mne
+ source = mne-python::git+http://github.com/mne-tools/mne-python.git
+ md5sums = SKIP
+
+pkgname = python2-mne-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f47be1b4be8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Gunnar Waterstraat <gunnar.waterstraat@gmx.de>
+pkgname=python2-mne-git
+pkgver=0.2.r13098.g05a09f7e5
+pkgrel=2
+pkgdesc="Open-source Python software for exploring, visualizing, and analyzing human neurophysiological data: MEG, EEG, sEEG, ECoG, and more."
+arch=('any')
+url="https://www.martinos.org/mne/stable/index.html"
+license=('BSD')
+depends=('python2>=2.7' 'python2-numpy>=1.8' 'python2-scipy>=0.12')
+optdepends=('python2-matplotlib' 'mayavi' 'python2-scikit-learn' 'python2-nibabel' 'python2-pandas' 'picard')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('mne-python::git+http://github.com/mne-tools/mne-python.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd mne-python
+ git describe --long | sed 's/v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "mne-python"
+ python2 setup.py build
+}
+
+package() {
+ cd "mne-python"
+ python2 setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}