summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..de6d7ac1347a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-musicbrainzngs
+ pkgdesc = Python2 bindings for Musicbrainz' NGS webservice
+ pkgver = 0.6
+ pkgrel = 6
+ url = https://github.com/alastair/python-musicbrainzngs
+ arch = any
+ license = BSD
+ makedepends = python2-setuptools
+ depends = python2
+ source = python-musicbrainzngs-0.6.tar.gz::https://github.com/alastair/python-musicbrainzngs/archive/v0.6.tar.gz
+ sha256sums = ec447bcab906fe7c4dbd714a1dff1b00adcd20d0011968df1a740e6b1fb09cb5
+
+pkgname = python2-musicbrainzngs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..16cfa00634fd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: twa022 <twa022 at gmail dot com>
+
+pkgname=python2-musicbrainzngs
+pkgver=0.6
+pkgrel=6
+pkgdesc="Python2 bindings for Musicbrainz' NGS webservice"
+arch=('any')
+url="https://github.com/alastair/python-musicbrainzngs"
+license=('BSD')
+depends=('python2')
+makedepends=('python2-setuptools')
+source=("${pkgname/2/}-${pkgver}.tar.gz::https://github.com/alastair/${pkgname/2/}/archive/v${pkgver}.tar.gz")
+sha256sums=('ec447bcab906fe7c4dbd714a1dff1b00adcd20d0011968df1a740e6b1fb09cb5')
+
+build() {
+ cd "${pkgname/2/}-${pkgver}"
+ python2 setup.py build
+}
+
+package() {
+ cd "${pkgname/2/}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}" --optimize='1'
+
+ install -Dm 644 COPYING -t "${pkgdir}"/usr/share/licenses/"${pkgname}"/
+}