summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c34630f51c69
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-oauth2client
+ pkgdesc = OAuth 2.0 client library
+ pkgver = 4.1.3
+ pkgrel = 1
+ url = https://github.com/googleapis/oauth2client
+ arch = any
+ license = Apache
+ makedepends = python2-setuptools
+ depends = python2
+ source = https://files.pythonhosted.org/packages/source/o/oauth2client/oauth2client-4.1.3.tar.gz
+ md5sums = 3a9eb781f685949c04946f6c09e4c11d
+
+pkgname = python2-oauth2client
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4c62cc10df7c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Adam Goldsmith <adam@adamgoldsmith.name>
+
+_name=oauth2client
+pkgname=python2-$_name
+pkgver=4.1.3
+pkgrel=1
+pkgdesc="OAuth 2.0 client library"
+arch=(any)
+url="https://github.com/googleapis/oauth2client"
+license=('Apache')
+depends=('python2')
+makedepends=('python2-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+md5sums=('3a9eb781f685949c04946f6c09e4c11d')
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --prefix=/usr --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: