summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD19
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8dc82ee114e7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by makepkg 4.2.0
+# Thu Jan 1 00:45:41 UTC 2015
+pkgbase = python2-piston-mini-client
+ pkgdesc = Library for writing clients for Django's Piston REST APIs (Python 2)
+ pkgver = 0.7.5
+ pkgrel = 1
+ url = https://launchpad.net/piston-mini-client
+ arch = any
+ license = GPL
+ makedepends = python2-distribute
+ depends = python2
+ depends = python2-httplib2
+ depends = python2-oauthlib
+ options = !emptydirs
+ source = https://launchpad.net/piston-mini-client/trunk/0.7.5/+download/piston-mini-client-0.7.5.tar.gz
+ sha512sums = 53ef74ea885e2cf403236543797ab32c483f3751c6b22c21a68160d398ae04b1670e6709541676699854975541aeab32600c5ef1611bc59afa40db36037faa1d
+
+pkgname = python2-piston-mini-client
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ee9dc9bcd062
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Xiao-Long Chen <chenxiaolong@cxl.epac.to>
+
+pkgname=python2-piston-mini-client
+pkgver=0.7.5
+pkgrel=1
+pkgdesc="Library for writing clients for Django's Piston REST APIs (Python 2)"
+arch=(any)
+url="https://launchpad.net/piston-mini-client"
+license=(GPL)
+depends=(python2 python2-httplib2 python2-oauthlib)
+makedepends=(python2-distribute)
+options=(!emptydirs)
+source=("https://launchpad.net/piston-mini-client/trunk/${pkgver}/+download/piston-mini-client-${pkgver}.tar.gz")
+sha512sums=('53ef74ea885e2cf403236543797ab32c483f3751c6b22c21a68160d398ae04b1670e6709541676699854975541aeab32600c5ef1611bc59afa40db36037faa1d')
+
+package() {
+ cd "piston-mini-client-${pkgver}"
+ python2 setup.py install --root="${pkgdir}/" --optimize=1
+}