summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD29
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d95cb1197f9b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Wed May 3 18:54:12 UTC 2017
+pkgbase = python2-prokaryote
+ pkgdesc = Python CellProfiler’s Java dependencies
+ pkgver = 1.0.11
+ pkgrel = 1
+ url = https://github.com/CellProfiler/prokaryote
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = python2-setuptools
+ makedepends = cython2
+ depends = jdk7-openjdk
+ depends = python2-numpy
+ source = https://github.com/CellProfiler/prokaryote/archive/1.0.11.tar.gz
+ sha256sums = c63ef0aa40513c707b5bc2defa971e00718097a474de2f52e8ca1347cafb82e4
+
+pkgname = python2-prokaryote
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..325699d8554e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Eugene Dvoretsky <radioxoma at gmail.com>
+
+pkgname=('python2-prokaryote')
+pkgver=1.0.11
+pkgrel=1
+pkgdesc="Python CellProfiler’s Java dependencies"
+arch=('i686' 'x86_64')
+url="https://github.com/CellProfiler/prokaryote"
+license=('BSD')
+depends=('jdk7-openjdk' 'python2-numpy')
+makedepends=('python2-setuptools' 'cython2')
+source=("https://github.com/CellProfiler/prokaryote/archive/${pkgver}.tar.gz")
+sha256sums=('c63ef0aa40513c707b5bc2defa971e00718097a474de2f52e8ca1347cafb82e4')
+
+prepare() {
+ cd "$srcdir/prokaryote-$pkgver"
+}
+
+build() {
+ cd "$srcdir/prokaryote-$pkgver"
+ # Warning! It will fetch more than 130 Mb.
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/prokaryote-$pkgver"
+ python2 setup.py install --root="$pkgdir"/ --optimize=1
+ install -D LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}