summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD18
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..958f5f1d7918
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python2-psycopg2ct
+ pkgdesc = psycopg2-compatible database adapter using ctypes (works with PyPy)
+ pkgver = 2.4.4
+ pkgrel = 1
+ url = http://pypi.python.org/pypi/psycopg2ct
+ arch = any
+ license = LGPL
+ makedepends = python2-distribute
+ depends = python2
+ depends = postgresql-libs
+ source = http://pypi.python.org/packages/source/p/psycopg2ct/psycopg2ct-2.4.4.tar.gz
+ md5sums = 249442785ce3e2597358b468e584020c
+
+pkgname = python2-psycopg2ct
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..076ab026ed07
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Contributor: Marti Raudsepp <marti@juffo.org>
+
+pkgname=python2-psycopg2ct
+pkgver=2.4.4
+pkgrel=1
+pkgdesc="psycopg2-compatible database adapter using ctypes (works with PyPy)"
+arch=(any)
+url="http://pypi.python.org/pypi/psycopg2ct"
+license=('LGPL')
+makedepends=('python2-distribute')
+depends=('python2' 'postgresql-libs')
+source=("http://pypi.python.org/packages/source/p/psycopg2ct/psycopg2ct-$pkgver.tar.gz")
+
+build() {
+ cd $srcdir/psycopg2ct-$pkgver
+ python2 setup.py install --root=$pkgdir
+}
+md5sums=('249442785ce3e2597358b468e584020c')