summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD32
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..73e4cb9596cb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Fri Feb 8 17:56:22 UTC 2019
+pkgbase = python2-pyamg
+ pkgdesc = PyAMG: Algebraic Multigrid Solvers in Python
+ pkgver = 4.0.0
+ pkgrel = 1
+ url = https://github.com/pyamg/pyamg
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = python2-setuptools
+ makedepends = pybind11
+ depends = python2
+ source = https://files.pythonhosted.org/packages/source/p/pyamg/pyamg-4.0.0.tar.gz
+ sha256sums = 3ceb38ffd86e29774e759486f2961599c8ed847459c68727493cadeaf115a38a
+
+pkgname = python2-pyamg
+ depends = python2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cc67faa7464d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Lukas Spies <lukas (at) photoqt _dot_ org>
+
+pkgname=('python2-pyamg')
+_module='pyamg'
+pkgver='4.0.0'
+pkgrel=1
+pkgdesc="PyAMG: Algebraic Multigrid Solvers in Python"
+url="https://github.com/pyamg/pyamg"
+depends=('python2')
+makedepends=('python2-setuptools' 'pybind11')
+license=('MIT')
+arch=('i686' 'x86_64')
+source=("https://files.pythonhosted.org/packages/source/p/pyamg/pyamg-${pkgver}.tar.gz")
+sha256sums=('3ceb38ffd86e29774e759486f2961599c8ed847459c68727493cadeaf115a38a')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python2 setup.py build
+}
+
+check() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python2 setup.py test
+}
+
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -D -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/license.md"
+}