summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD22
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9fa54de9c0ce
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Sun Feb 14 22:57:06 UTC 2016
+pkgbase = python2-pycommand
+ pkgdesc = A clean and simplistic alternative for argparse, optparse and getopt
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/pycommand
+ arch = any
+ license = custom:ISC
+ makedepends = python2-distribute
+ depends = python2
+ source = http://pypi.python.org/packages/source/p/pycommand/pycommand-0.3.0.tar.gz
+ md5sums = 2d8197b987c5096ae5646f0155f1aa1d
+
+pkgname = python2-pycommand
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bab8b293f46d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Tom Willemse <tom@ryuslash.org>
+
+_python=python2
+_name=pycommand
+
+pkgname=$_python-pycommand
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="A clean and simplistic alternative for argparse, optparse and getopt"
+depends=('python2')
+makedepends=('python2-distribute')
+arch=('any')
+source=("http://pypi.python.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+md5sums=('2d8197b987c5096ae5646f0155f1aa1d')
+url="https://pypi.python.org/pypi/pycommand"
+license=('custom:ISC')
+
+package() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ $_python setup.py install --root="$pkgdir"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}