summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD31
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..993591f784e5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Tue Mar 14 16:47:53 UTC 2017
+pkgbase = python2-pyina-git
+ pkgdesc = MPI parallel map and cluster scheduling from git master
+ pkgver = 152.5d8ba73
+ pkgrel = 1
+ url = http://www.cacr.caltech.edu/~mmckerns/pyina.htm
+ arch = any
+ license = BSD
+ makedepends = python2-setuptools
+ depends = python2
+ depends = python2-dill
+ depends = python2-mpi4py
+ depends = python2-pox
+ depends = python2-pathos
+ provides = python2-pyina
+ source = git+https://github.com/uqfoundation/pyina#branch=master
+ md5sums = SKIP
+
+pkgname = python2-pyina-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2216c41d4251
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+pkg/
+src/
+*.tgz
+*.tar.gz
+*.tar.xz
+pyina/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aa3f630a4c61
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+pkgname=('python2-pyina-git')
+pkgver=152.5d8ba73
+pkgrel=1
+pkgdesc="MPI parallel map and cluster scheduling from git master"
+url="http://www.cacr.caltech.edu/~mmckerns/pyina.htm"
+depends=('python2' 'python2-dill' 'python2-mpi4py' 'python2-pox' 'python2-pathos')
+#optdepends=('python2-pyre')
+makedepends=('python2-setuptools')
+provides=('python2-pyina')
+conflics=('python2-pyina')
+license=('BSD')
+arch=('any')
+
+source=("git+https://github.com/uqfoundation/pyina#branch=master")
+md5sums=('SKIP')
+
+pkgver() {
+ cd pyina
+ #echo $(git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g')
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+build() {
+ cd pyina
+ python2 setup.py build
+}
+
+package() {
+ cd pyina
+ python2 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}