summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..10d7e3bfeb08
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-pylnk
+ pkgdesc = Windows LNK File Parser and Creator.
+ pkgver = 0.2
+ pkgrel = 2
+ url = https://pypi.python.org/pypi/pylnk/
+ arch = any
+ license = LGPL
+ makedepends = python2-setuptools
+ depends = python2
+ source = https://pypi.python.org/packages/fb/08/33f44f78d9735d45cdf19c9794d2898266ce176c83e8cbc88e3eecc59216/pylnk-0.2.tar.gz
+ sha1sums = 5a640d56cba340800c3834797f10c75d23828fd5
+
+pkgname = python2-pylnk
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a5dbce66c5a2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Paul Taylor <bao7uo at gmail dot com>
+# Contributer: BlackArch
+
+pkgname='python2-pylnk'
+pkgver='0.2'
+pkgrel=2
+pkgdesc='Windows LNK File Parser and Creator.'
+arch=('any')
+url='https://pypi.python.org/pypi/pylnk/'
+license=('LGPL')
+depends=('python2')
+makedepends=('python2-setuptools')
+source=("https://pypi.python.org/packages/fb/08/33f44f78d9735d45cdf19c9794d2898266ce176c83e8cbc88e3eecc59216/pylnk-${pkgver}.tar.gz")
+sha1sums=('5a640d56cba340800c3834797f10c75d23828fd5')
+
+build() {
+ cd "$srcdir/pylnk-$pkgver"
+
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/pylnk-$pkgver"
+
+ python2 setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
+}
+