summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD31
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fba79325c2f8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = python2-pynlpl-git
+ pkgdesc = Python Natural Language Processing Library (pronounce as: pineapple). Contains various modules useful for common, and less common, NLP tasks. Includes full FoLiA library.
+ pkgver = 1324
+ pkgrel = 2
+ url = https://github.com/proycon/pynlpl
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = python2
+ depends = python2-setuptools
+ depends = python2-lxml
+ depends = python2-httplib2
+ depends = python2-numpy
+ provides = python2-pynlpl
+ conflicts = python2-pynlpl
+ source = git://github.com/proycon/pynlpl.git
+ md5sums = SKIP
+
+pkgname = python2-pynlpl-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7b51cb94a2fd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+_pkgname=python2-pynlpl
+pkgname=${_pkgname}-git
+pkgver=1324
+pkgrel=2
+pkgdesc='Python Natural Language Processing Library (pronounce as: pineapple). Contains various modules useful for common, and less common, NLP tasks. Includes full FoLiA library.'
+arch=('i686' 'x86_64')
+url="https://github.com/proycon/pynlpl"
+license=('GPL')
+depends=('python2' 'python2-setuptools' 'python2-lxml' 'python2-httplib2' 'python2-numpy')
+makedepends=('git')
+provides=("${_pkgname}")
+conflicts=("python2-pynlpl")
+source=("git://github.com/proycon/pynlpl.git")
+_gitname=("pynlpl")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ git rev-list --count HEAD
+}
+
+build() {
+ cd "$srcdir/$_gitname"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ python2 setup.py install --prefix=/usr --root="${pkgdir}"
+}
+