summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD27
2 files changed, 20 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5ae931ab2290..584d353895a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python2-pyphen
pkgdesc = Library to hyphenate text using included or external Hunspell hyphenation dictionaries
- pkgver = 0.9.1
+ pkgver = 0.9.4
pkgrel = 1
url = http://pyphen.org/
arch = any
@@ -8,8 +8,8 @@ pkgbase = python2-pyphen
license = LGPL2.1
license = MPL
makedepends = python2
- source = https://pypi.python.org/packages/source/P/Pyphen/Pyphen-0.9.1.tar.gz
- md5sums = 024fe88b78e7b65f02cba1c3165223e6
+ source = https://github.com/Kozea/Pyphen/archive/0.9.4.tar.gz
+ md5sums = 5b27217dde553bc0fdd3f7d3878e85a4
pkgname = python2-pyphen
diff --git a/PKGBUILD b/PKGBUILD
index 9baf88d4f8d7..7ce7a9f621b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,8 @@
-# Maintainer: Marti Raudsepp <marti@juffo.org>
-_pypi_name='Pyphen'
-pkgver=0.9.1
+# Maintainer: quomoow <quomoow@gmail.com>
+
+pkgname="python2-pyphen"
+_pkgname="Pyphen"
+pkgver=0.9.4
pkgrel=1
pkgdesc="Library to hyphenate text using included or external Hunspell hyphenation dictionaries"
license=('GPL2' 'LGPL2.1' 'MPL')
@@ -8,13 +10,18 @@ arch=('any')
url="http://pyphen.org/"
makedepends=('python2')
depends=()
-pkgname="python2-pyphen"
-_pypi_name_inital=$(echo ${_pypi_name}|cut -c1)
-source=("https://pypi.python.org/packages/source/${_pypi_name_inital}/${_pypi_name}/${_pypi_name}-${pkgver}.tar.gz")
+_pkgname_initial=$(echo ${_pkgname}|cut -c1)
+source=("https://github.com/Kozea/${_pkgname}/archive/${pkgver}.tar.gz")
+md5sums=('5b27217dde553bc0fdd3f7d3878e85a4')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ python2 setup.py build
+}
package() {
- cd "$srcdir/$_pypi_name-$pkgver"
- python2 setup.py install --root="$pkgdir/" --optimize=1
- #rm -rf "$pkgdir/usr/bin" # Avoid a conflict: only keep the Py3 executable.
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ python2 setup.py install --root="${pkgdir}" --optimize=1
}
-md5sums=('024fe88b78e7b65f02cba1c3165223e6')