summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD23
2 files changed, 16 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e5d8f0077f21..e2b8660db5b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,10 +5,10 @@ pkgbase = python2-pysocks
url = https://github.com/urllib3/PySocks
arch = any
license = BSD
- makedepends = python2--setuptools
- source = -f4c3cd9897898de69e136c92fd957fd989ee08ec.tar.gz::https://github.com/urllib3/PySocks/archive/f4c3cd9897898de69e136c92fd957fd989ee08ec.tar.gz
- source = 0001-Fix_HTTP_basic_auth.patch::https://github.com/Anorov//pull/147.patch
- source = 0002-Change_error_type_to_match_native_socket_error.patch::https://github.com/Anorov//pull/154.patch
+ makedepends = python2-setuptools
+ source = PySocks-f4c3cd9897898de69e136c92fd957fd989ee08ec.tar.gz::https://github.com/urllib3/PySocks/archive/f4c3cd9897898de69e136c92fd957fd989ee08ec.tar.gz
+ source = 0001-Fix_HTTP_basic_auth.patch::https://github.com/Anorov/PySocks/pull/147.patch
+ source = 0002-Change_error_type_to_match_native_socket_error.patch::https://github.com/Anorov/PySocks/pull/154.patch
source = 0003-Properly_convert_unsigned_integer_fix_urllib3_PySocks_issue_4.patch::https://github.com/urllib3/PySocks/pull/5.patch
b2sums = 1c7869c0c49ca44db02b4b9118f703d41be0902d78d38258ed8e93db897736612a9793be4b648495e58d801afa58f14c814243c97055b8f2781d0ed286909c9d
b2sums = c43421895dadd00a7845aff973e14eebc12284e4dac71a8c864803beb9e6d418971c518172a194249aece031118e35de074bbf5233a9c5359b3fcb7b99da4f2e
@@ -17,4 +17,4 @@ pkgbase = python2-pysocks
pkgname = python2-pysocks
depends = python2
- provides = python2-socks=1.7.1
+ provides = python2-pysocks=1.7.1
diff --git a/PKGBUILD b/PKGBUILD
index 8bb101568298..c55835573f07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,20 +27,20 @@ license=(
'BSD'
)
makedepends=(
- "${_py}--setuptools"
+ "${_py}-setuptools"
)
checkdepends=()
[[ "${_checks}" == 'true' ]] && \
checkdepends+=(
# 'lib32-glibc'
-# 'python2-twisted'
- 'python2-tornado'
+# "${_py}-twisted'
+ "${_py}-tornado"
)
-_tarname="${_name}-${_commit}"
+_tarname="${_Pkg}-${_commit}"
source=(
"${_tarname}.tar.gz::${url}/archive/${_commit}.tar.gz"
- "0001-Fix_HTTP_basic_auth.patch::https://github.com/Anorov/${_name}/pull/147.patch"
- "0002-Change_error_type_to_match_native_socket_error.patch::https://github.com/Anorov/${_name}/pull/154.patch"
+ "0001-Fix_HTTP_basic_auth.patch::https://github.com/Anorov/${_Pkg}/pull/147.patch"
+ "0002-Change_error_type_to_match_native_socket_error.patch::https://github.com/Anorov/${_Pkg}/pull/154.patch"
"0003-Properly_convert_unsigned_integer_fix_urllib3_PySocks_issue_4.patch::${url}/pull/5.patch"
)
b2sums=(
@@ -69,9 +69,9 @@ prepare() {
echo
done
printf \
- "Changing hashbangs in *.py files to refer to 'python2'... "
+ "Changing hashbangs in *.py files to refer to '${_py}'... "
sed \
- -e '1s|#![ ]*/[a-zA-Z0-9./_ ]*python.*|#!/usr/bin/env python2|' \
+ -e "1s|#![ ]*/[a-zA-Z0-9./_ ]*python.*|#!/usr/bin/env ${_py}|" \
-i \
$( \
find \
@@ -120,15 +120,14 @@ _check() {
package() {
depends=(
- 'python2'
+ "${_py}"
)
provides=(
- "python2-socks=${pkgver%.r*}"
+ "${pkgname}=${pkgver%.r*}"
)
-
cd \
"${_tarname}"
- python2 \
+ "${_py}" \
setup.py \
install \
--root="${pkgdir}" \