summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
-rw-r--r--setup.cfg5
3 files changed, 23 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ab307d8b8061..68b3416b0353 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,16 @@
-pkgbase = python-pysqlite
+# Generated by mksrcinfo v8
+# Fri Feb 14 14:35:03 UTC 2020
+pkgbase = python2-pysqlite
pkgdesc = A Python DB-API 2.0 interface for the SQLite embedded relational database engine
- pkgver = 2.8.1
+ pkgver = 2.8.3
pkgrel = 1
url = https://pypi.python.org/pypi/pysqlite
- arch = any
+ arch = x86_64
license = custom
depends = python2
depends = sqlite
- conflicts = python-pysqlite<=2.8.1-1
- replaces = python-pysqlite<=2.8.1-1
- source = https://pypi.python.org/packages/source/p/pysqlite/pysqlite-2.8.1.tar.gz
- source = setup.cfg
- sha256sums = 75cae18f9646f2a6137e1fb5302dba674b6982eeab3a2829377e98b13cfea066
- sha256sums = 37eeb06fdb89d5dd7674f8f8094614c21468b6b469169b1db5981632aa573dca
+ source = https://pypi.python.org/packages/source/p/pysqlite/pysqlite-2.8.3.tar.gz
+ sha256sums = 17d3335863e8cf8392eea71add33dab3f96d060666fe68ab7382469d307f4490
pkgname = python2-pysqlite
diff --git a/PKGBUILD b/PKGBUILD
index feec16329054..fec5a133758b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,37 @@
-pkgbase=python-pysqlite
+# Maintainer: Thore Bödecker <me [at] foxxx0 [dot] de>
+# Contributor: Daniel Milde <daniel@milde.cz>
+
pkgname=python2-pysqlite
-pkgver=2.8.1
+_pkgname="${pkgname#python2-}"
+pkgver=2.8.3
pkgrel=1
pkgdesc="A Python DB-API 2.0 interface for the SQLite embedded relational database engine"
license=('custom')
-arch=('any')
+arch=('x86_64')
url="https://pypi.python.org/pypi/pysqlite"
depends=('python2' 'sqlite')
-conflicts=('python-pysqlite<=2.8.1-1')
-replaces=('python-pysqlite<=2.8.1-1')
-source=(https://pypi.python.org/packages/source/p/pysqlite/pysqlite-${pkgver}.tar.gz
- setup.cfg)
-sha256sums=('75cae18f9646f2a6137e1fb5302dba674b6982eeab3a2829377e98b13cfea066'
- '37eeb06fdb89d5dd7674f8f8094614c21468b6b469169b1db5981632aa573dca')
+source=("https://pypi.python.org/packages/source/p/pysqlite/pysqlite-${pkgver}.tar.gz")
+sha256sums=('17d3335863e8cf8392eea71add33dab3f96d060666fe68ab7382469d307f4490')
prepare() {
- cp "${srcdir}/setup.cfg" pysqlite-${pkgver}
+ :
}
build() {
- cd pysqlite-${pkgver}
+ cd "${srcdir}/${_pkgname}-${pkgver}"
python2 setup.py build
}
check() {
- cd pysqlite-${pkgver}/build/lib.*/
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ py2_version="$(python2 -c 'import sys; print "{}.{}".format(sys.version_info.major, sys.version_info.minor)')"
+ cd "build/lib.linux-${arch}-${py2_version}/"
python2 -c "from pysqlite2 import test; test.test()"
}
-package_python2-pysqlite() {
- cd pysqlite-${pkgver}
- python2 setup.py install --root="${pkgdir}"
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}/" --optimize=1
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
rm -r "${pkgdir}/usr/pysqlite2-doc"
}
diff --git a/setup.cfg b/setup.cfg
deleted file mode 100644
index ba6c77075682..000000000000
--- a/setup.cfg
+++ /dev/null
@@ -1,5 +0,0 @@
-[build_ext]
-define=
-include_dirs=/usr/include
-library_dirs=/usr/lib
-libraries=sqlite3