summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD22
2 files changed, 16 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 189fd5b07e2b..9f62d5a662b9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = python2-pytrie
- pkgdesc = A pure Python implementation of the trie data structure.
- pkgver = 0.2
+ pkgdesc = A pure Python2 implementation of the trie data structure.
+ pkgver = 0.3.1
pkgrel = 1
- url = http://bitbucket.org/gsakkis/pytrie/
+ url = https://github.com/gsakkis/pytrie
arch = any
- license = UNKNOWN
+ license = BSD
makedepends = python2
depends = python2
- source = https://pypi.python.org/packages/source/P/PyTrie/PyTrie-0.2.tar.gz
- md5sums = 5997b46c854a68bc588f4527c987663a
+ source = https://pypi.python.org/packages/source/P/PyTrie/PyTrie-0.3.1.tar.gz
+ md5sums = f7c7184124013abcc18a3e3b638d32ae
pkgname = python2-pytrie
diff --git a/PKGBUILD b/PKGBUILD
index 698a74456898..41e6bb6e34bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,21 @@
-#Automatically generated by pip2arch on 2015-06-01
-
pkgname=python2-pytrie
-pkgver=0.2
+pkgver=0.3.1
pkgrel=1
-pkgdesc="A pure Python implementation of the trie data structure."
-url="http://bitbucket.org/gsakkis/pytrie/"
-depends=('python2' )
-makedepends=('python2' )
-license=('UNKNOWN')
+pkgdesc="A pure Python2 implementation of the trie data structure."
+url="https://github.com/gsakkis/pytrie"
+depends=('python2')
+makedepends=('python2')
+license=('BSD')
arch=('any')
-source=('https://pypi.python.org/packages/source/P/PyTrie/PyTrie-0.2.tar.gz')
-md5sums=('5997b46c854a68bc588f4527c987663a')
+source=(https://pypi.python.org/packages/source/P/PyTrie/PyTrie-$pkgver.tar.gz)
+md5sums=('f7c7184124013abcc18a3e3b638d32ae')
build() {
- cd $srcdir/PyTrie-0.2
+ cd $srcdir/PyTrie-$pkgver
python2 setup.py build
}
package() {
- cd $srcdir/PyTrie-0.2
+ cd $srcdir/PyTrie-$pkgver
python2 setup.py install --root="$pkgdir" --optimize=1
}