summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f10b74750bdb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-qtfaststart
+ pkgdesc = Quicktime atom positioning in Python for fast streaming
+ pkgver = 1.8
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/qtfaststart
+ arch = any
+ license = MIT
+ makedepends = python2-setuptools
+ depends = python2
+ options = !emptydirs
+ source = https://pypi.python.org/packages/source/q/qtfaststart/qtfaststart-1.8.tar.gz
+ sha256sums = b0442315311f1c1130a34e4e6b04557f5f4aa332ac40bfb1d761418866749241
+
+pkgname = python2-qtfaststart \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5c746b5704df
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Zachary Riedlshah <git@zacharyrs.me>
+
+name='qtfaststart'
+pkgname=python2-$name
+pkgver=1.8
+pkgrel=1
+pkgdesc="Quicktime atom positioning in Python for fast streaming"
+arch=('any')
+url="https://pypi.python.org/pypi/$name"
+license=('MIT')
+makedepends=('python2-setuptools')
+depends=('python2')
+options=(!emptydirs)
+
+source=("https://pypi.python.org/packages/source/${name::1}/${name}/${name}-${pkgver}.tar.gz")
+sha256sums=('b0442315311f1c1130a34e4e6b04557f5f4aa332ac40bfb1d761418866749241')
+
+package() {
+ cd "$srcdir/$name-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}