summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD24
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a8d85fd4207f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python2-rax-backup-schedule-python-novaclient-ext
+ pkgdesc = Novaclient Extension for Backup Schedule
+ pkgver = 0.1.2
+ pkgrel = 5
+ url = http://pypi.python.org/pypi/rax_backup_schedule_python_novaclient_ext
+ arch = any
+ license = GPL
+ makedepends = python2-setuptools
+ depends = python2
+ depends = python2-novaclient
+ depends = python2-httplib2
+ depends = python2-prettytable
+ depends = python2-simplejson
+ depends = python2-iso8601
+ provides = python2-rax-backup-schedule-python-novaclient-ext=0.1.2
+ source = https://pypi.python.org/packages/source/r/rax_backup_schedule_python_novaclient_ext/rax_backup_schedule_python_novaclient_ext-0.1.2.tar.gz
+ md5sums = 5a4f9da670e5171623ee25b48d5b30a1
+
+pkgname = python2-rax-backup-schedule-python-novaclient-ext
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3db029e57fdc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Troy C < rstrox -ta yahoo -tod com >
+
+pkgname=python2-rax-backup-schedule-python-novaclient-ext
+pkgver=0.1.2
+pkgrel=5
+pkgdesc="Novaclient Extension for Backup Schedule"
+arch=('any')
+url="http://pypi.python.org/pypi/rax_backup_schedule_python_novaclient_ext"
+license=('GPL')
+depends=('python2' 'python2-novaclient' 'python2-httplib2' 'python2-prettytable' 'python2-simplejson' 'python2-iso8601')
+makedepends=('python2-setuptools')
+provides=("$pkgname=$pkgver")
+source=("https://pypi.python.org/packages/source/r/rax_backup_schedule_python_novaclient_ext/rax_backup_schedule_python_novaclient_ext-${pkgver}.tar.gz")
+md5sums=('5a4f9da670e5171623ee25b48d5b30a1')
+
+build() {
+ cd "$srcdir/rax_backup_schedule_python_novaclient_ext-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/rax_backup_schedule_python_novaclient_ext-$pkgver"
+ python2 setup.py install --root=${pkgdir}
+}