summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD30
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..03a0d65c647a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python2-timbl-git
+ pkgdesc = Python binding for Timbl, a k-Nearest Neighbours machine learning suite
+ pkgver = 41
+ pkgrel = 3
+ url = https://github.com/proycon/python-timbl
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = libtool
+ depends = python2
+ depends = libxml2
+ depends = boost
+ depends = timbl
+ provides = python2-timbl
+ source = git://github.com/proycon/python-timbl.git
+ md5sums = SKIP
+
+pkgname = python2-timbl-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0161e41027e3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+_pkgname=python2-timbl
+pkgname=${_pkgname}-git
+pkgver=41
+pkgrel=3
+pkgdesc='Python binding for Timbl, a k-Nearest Neighbours machine learning suite'
+arch=('i686' 'x86_64')
+url="https://github.com/proycon/python-timbl"
+license=('GPL')
+depends=('python2' 'libxml2' 'boost' 'timbl')
+makedepends=('git' 'libtool')
+provides=("${_pkgname}")
+source=("git://github.com/proycon/python-timbl.git")
+_gitname=("python-timbl")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ git rev-list --count HEAD
+}
+
+build() {
+ cd "$srcdir/$_gitname"
+ python2 setup2.py build_ext --timbl-library-dir=/usr/lib --timbl-include-dir=/usr/include/ build
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ python2 setup2.py build_ext --timbl-library-dir=/usr/lib --timbl-include-dir=/usr/include/ install --prefix=/usr --root="${pkgdir}"
+}
+