summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD22
-rw-r--r--splitting.patch21
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e633f254d1ae
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python2-wordaxe
+ pkgdesc = Hyphenation support for reportlab
+ pkgver = 1.0.1
+ pkgrel = 5
+ url = http://deco-cow.sf.net
+ arch = i686
+ arch = x86_64
+ license = Apache
+ depends = python2
+ depends = setuptools
+ depends = docutils
+ depends = python2-reportlab
+ depends = python-pyhyphen
+ source = http://downloads.sourceforge.net/deco-cow/wordaxe-1.0.1.zip
+ source = splitting.patch
+ md5sums = b1b5e4b2a3abec5a352d84e65c3b0dec
+ md5sums = 60212f5716c1b9e2e57d8f1da3174654
+
+pkgname = python2-wordaxe
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..abfcf5bad967
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Contributor: Roberto Alsina <ralsina@kde.org>
+# Contributor: Fabien Devaux <fdev31@gmail.com>
+
+pkgname=python2-wordaxe
+pkgver=1.0.1
+pkgrel=5
+pkgdesc="Hyphenation support for reportlab"
+arch=('i686' 'x86_64')
+url="http://deco-cow.sf.net"
+license=('Apache')
+depends=('python2' 'setuptools' 'docutils' 'python2-reportlab' 'python-pyhyphen')
+source=(http://downloads.sourceforge.net/deco-cow/wordaxe-$pkgver.zip splitting.patch)
+
+build() {
+ cd $srcdir
+ patch -p0 < splitting.patch
+ cd wordaxe-$pkgver
+ python2 setup.py install --root=$startdir/pkg || exit 1
+ install -D $startdir/src/wordaxe-$pkgver/docs/license.txt $startdir/pkg/usr/share/licenses/python-wordaxe/COPYING
+}
+md5sums=('b1b5e4b2a3abec5a352d84e65c3b0dec'
+ '60212f5716c1b9e2e57d8f1da3174654')
diff --git a/splitting.patch b/splitting.patch
new file mode 100644
index 000000000000..7a40fef077a9
--- /dev/null
+++ b/splitting.patch
@@ -0,0 +1,21 @@
+diff -ru wordaxe-1.0.1-orig/wordaxe/rl/NewParagraph.py wordaxe-1.0.1/wordaxe/rl/NewParagraph.py
+--- wordaxe-1.0.1-orig/wordaxe/rl/NewParagraph.py 2010-04-15 10:34:19.000000000 -0300
++++ wordaxe-1.0.1/wordaxe/rl/NewParagraph.py 2010-04-15 10:37:11.000000000 -0300
+@@ -657,7 +657,7 @@
+
+ self.width = availW
+ self.height = sumHeight
+- if sumHeight > availH:
++ if sumHeight and sumHeight > availH:
+ #print id(self), "needs splitting"
+ #print "lines[-1]:", lines[-1]
+ #print "frags_remaining:", frags_remaining
+@@ -687,7 +687,7 @@
+ else:
+ #print id(self), "fits"
+ unused = []
+- assert self.height <= availH, (id(self), self.height, availH)
++ #assert self.height <= availH, (id(self), self.height, availH)
+ self._cache['lines'] = lines
+ self._cache['unused'] = unused
+ self._cache['avail'] = (availW, availH)