summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..38b69759b41d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python3-lxc
+ pkgdesc = Python3.x bindings for liblxc
+ pkgver = 3.0.3
+ pkgrel = 1
+ url = https://github.com/lxc/python3-lxc
+ arch = x86_64
+ license = LGPL2.1
+ depends = python3
+ depends = lxc
+ source = https://github.com/lxc/python3-lxc/archive/python3-lxc-3.0.3.tar.gz
+ md5sums = e4e0b542db6021cd0bf0b16520ad3285
+
+pkgname = python3-lxc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fbeb7f7a9429
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Andrew Steinke <rkcf@rkcf.me>
+
+pkgname='python3-lxc'
+pkgrel=1
+pkgver=3.0.3
+pkgdesc="Python3.x bindings for liblxc"
+depends=('python3' 'lxc')
+url="https://github.com/lxc/python3-lxc"
+license=('LGPL2.1')
+arch=('x86_64')
+source=("$url/archive/$pkgname-$pkgver.tar.gz")
+md5sums=('e4e0b542db6021cd0bf0b16520ad3285')
+
+build() {
+ # for some reason package extracts with a double package name
+ cd "$srcdir/$pkgname-$pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}