summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--ChangeLog6
-rw-r--r--PKGBUILD10
3 files changed, 17 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d77e30cd7189..494962aa8fb6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python32
pkgdesc = Next generation of the python high-level scripting language
pkgver = 3.2.6
- pkgrel = 3
+ pkgrel = 4
url = http://www.python.org/
changelog = ChangeLog
arch = i686
@@ -10,6 +10,7 @@ pkgbase = python32
makedepends = tk
makedepends = sqlite
makedepends = valgrind
+ makedepends = gcc11
depends = expat
depends = bzip2
depends = gdbm
@@ -18,6 +19,7 @@ pkgbase = python32
depends = zlib
optdepends = tk: for tkinter
optdepends = sqlite
+ provides = python=3.2.6
source = http://www.python.org/ftp/python/3.2.6/Python-3.2.6.tar.xz
source = readline-6.3.patch
source = openssl-1.0.2g.patch
diff --git a/ChangeLog b/ChangeLog
index cb7953945845..f711ff791831 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,9 @@
+2022-06-19 Danilo J. S. Bellini <danilo.bellini@gmail.com>
+
+ * Using gcc 11 since gcc 12 was resulting in SEGFAULT while linking.
+ * Add "provides" info.
+ * Fix shebangs to python3.2
+
2022-01-22 Danilo J. S. Bellini <danilo.bellini@gmail.com>
* Restored/recreated the package from AUR history.
diff --git a/PKGBUILD b/PKGBUILD
index f1f1a1b3a88a..615c4fcc7b7c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,14 +5,15 @@
# Contributor: Simon Sapin <simon.sapin at kozea.fr>
pkgname=python32
pkgver=3.2.6
-pkgrel=3
+pkgrel=4
_pybasever=3.2
pkgdesc="Next generation of the python high-level scripting language"
arch=('i686' 'x86_64')
license=('custom')
url="http://www.python.org/"
+provides=("python=$pkgver")
depends=('expat' 'bzip2' 'gdbm' 'openssl-1.0' 'libffi' 'zlib')
-makedepends=('tk' 'sqlite' 'valgrind')
+makedepends=('tk' 'sqlite' 'valgrind' 'gcc11')
optdepends=('tk: for tkinter' 'sqlite')
changelog=ChangeLog
source=("http://www.python.org/ftp/python/${pkgver%rc*}/Python-${pkgver}.tar.xz"
@@ -35,6 +36,10 @@ build() {
# FS#23997
sed -i -e "s|^#.* /usr/local/bin/python|#!/usr/bin/python|" Lib/cgi.py
+ # Fix shebangs
+ find -name '*.py*' \
+ -exec sed -ri '1s/^(#!.*python)3?\s*$/\1'$_pybasever'/' '{}' \;
+
# Ensure that we are using the system copy of various libraries (expat, zlib and libffi),
# rather than copies shipped in the tarball
rm -rf Modules/expat
@@ -43,6 +48,7 @@ build() {
export CPPFLAGS="-I/usr/include/openssl-1.0"
export LDFLAGS="-L/usr/lib/openssl-1.0"
+ export CC=gcc-11
./configure --prefix=/usr \
--enable-shared \
--with-threads \