summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD17
2 files changed, 15 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c7f2744c91a0..6e7ec4797a39 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,16 @@
-# Generated by mksrcinfo v8
-# Mon Sep 4 08:44:14 UTC 2017
pkgbase = qcustomplot-qt5
pkgdesc = Plotting library for Qt5
- pkgver = 2.0.0_beta
- pkgrel = 2
+ pkgver = 2.0.1
+ pkgrel = 1
url = http://www.qcustomplot.com
arch = x86_64
arch = i686
license = GPL
depends = qt5-base
- source = QCustomPlot-2.0.0_beta.tar.gz::http://www.qcustomplot.com/release/2.0.0-beta/QCustomPlot.tar.gz
- source = QCustomPlot-sharedlib-2.0.0_beta.tar.gz::http://www.qcustomplot.com/release/2.0.0-beta/QCustomPlot-sharedlib.tar.gz
- md5sums = a4196694eb08de800a794cc297e046dd
- md5sums = 294fdf8834e8ef0fa2c1e830f936b7fc
+ source = QCustomPlot-2.0.1.tar.gz::http://www.qcustomplot.com/release/2.0.1/QCustomPlot.tar.gz
+ source = QCustomPlot-sharedlib-2.0.1.tar.gz::http://www.qcustomplot.com/release/2.0.1/QCustomPlot-sharedlib.tar.gz
+ sha256sums = f23f08b1294fea4c99b90afbd30fef6a85c294e5a6269164e1ee9f57dca9edfd
+ sha256sums = cca0847dad29beff57b36e21efd1a0c40f74781f4648fb0921fb269d4f61d583
pkgname = qcustomplot-qt5
diff --git a/PKGBUILD b/PKGBUILD
index 413e7ef530b6..621f02d6543b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,26 @@
-# Maintainer: Morten Linderud <morten@linderud.pw>
+# Maintainer: Aleksandar Trifunović <akstrfn at gmail dot com>
+# Contibutor: Morten Linderud <morten@linderud.pw>
# Contibutor: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
pkgname=qcustomplot-qt5
-pkgver=2.0.0_beta
-pkgrel=2
+pkgver=2.0.1
+pkgrel=1
pkgdesc="Plotting library for Qt5"
url="http://www.qcustomplot.com"
arch=('x86_64' 'i686')
license=('GPL')
depends=('qt5-base')
-source=("QCustomPlot-$pkgver.tar.gz::http://www.qcustomplot.com/release/${pkgver//_/-}/QCustomPlot.tar.gz"
- "QCustomPlot-sharedlib-$pkgver.tar.gz::http://www.qcustomplot.com/release/${pkgver//_/-}/QCustomPlot-sharedlib.tar.gz")
-md5sums=('a4196694eb08de800a794cc297e046dd'
- '294fdf8834e8ef0fa2c1e830f936b7fc')
+source=("QCustomPlot-$pkgver.tar.gz::$url/release/${pkgver//_/-}/QCustomPlot.tar.gz"
+ "QCustomPlot-sharedlib-$pkgver.tar.gz::$url/release/${pkgver//_/-}/QCustomPlot-sharedlib.tar.gz")
+sha256sums=('f23f08b1294fea4c99b90afbd30fef6a85c294e5a6269164e1ee9f57dca9edfd'
+ 'cca0847dad29beff57b36e21efd1a0c40f74781f4648fb0921fb269d4f61d583')
build() {
cd "${srcdir}"
# fix path to source files
sed -i 's|../../qcustomplot|../../qcustomplot/qcustomplot|g' \
- "${srcdir}/qcustomplot-sharedlib/sharedlib-compilation/sharedlib-compilation.pro"
+ "${srcdir}/qcustomplot-sharedlib/sharedlib-compilation/sharedlib-compilation.pro"
qmake-qt5 "${srcdir}/qcustomplot-sharedlib/sharedlib-compilation/sharedlib-compilation.pro"
make release