summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD40
-rw-r--r--fix_lib_64.patch12
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c28a6cba0bc5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = qoauth-git
+ pkgdesc = A Qt-based C++ library for OAuth authorization scheme
+ pkgver = v1.0.30.g02fbc13
+ pkgrel = 1
+ url = https://github.com/ayoy/qoauth
+ arch = i686
+ arch = x86_64
+ license = LGPL3
+ makedepends = git
+ depends = qca-qt5
+ provides = qoauth
+ conflicts = qoauth
+ source = git://github.com/ayoy/qoauth.git
+ source = fix_lib_64.patch
+ md5sums = SKIP
+ md5sums = 75d2e129f4a8b8994b48699d71e170b4
+
+pkgname = qoauth-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7bbd4ceb1a94
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Cesar Alcalde <lambda512 _at_ gmail.com>
+
+pkgname=qoauth-git
+pkgver=v1.0.30.g02fbc13
+pkgrel=1
+pkgdesc='A Qt-based C++ library for OAuth authorization scheme'
+arch=('i686' 'x86_64')
+url='https://github.com/ayoy/qoauth'
+license=('LGPL3')
+depends=('qca-qt5')
+makedepends=('git')
+provides=('qoauth')
+conflicts=('qoauth')
+source=("git://github.com/ayoy/qoauth.git"
+ 'fix_lib_64.patch')
+md5sums=('SKIP'
+ '75d2e129f4a8b8994b48699d71e170b4')
+
+pkgver() {
+ cd qoauth
+ local ver="$(git describe --long)"
+ printf "%s" "${ver//-/.}"
+}
+
+prepare() {
+ cd qoauth
+ patch -p1 -i "${srcdir}"/fix_lib_64.patch
+}
+
+build () {
+ cd qoauth
+ qmake
+ make
+}
+
+package() {
+ cd qoauth
+ make INSTALL_ROOT="${pkgdir}" install
+}
diff --git a/fix_lib_64.patch b/fix_lib_64.patch
new file mode 100644
index 000000000000..e6d5b095df09
--- /dev/null
+++ b/fix_lib_64.patch
@@ -0,0 +1,12 @@
+diff -aur qoauth-original//src/src.pro qoauth/src/src.pro
+--- qoauth-original//src/src.pro 2010-06-21 15:36:08.000000000 +0200
++++ qoauth/src/src.pro 2010-06-21 15:55:05.000000000 +0200
+@@ -62,7 +62,7 @@
+ pkgconfig.files = qoauth.pc
+
+ contains(QMAKE_HOST.arch, x86_64) {
+- target.path = $${INSTALL_PREFIX}/lib64
++ target.path = $${INSTALL_PREFIX}/lib
+ } else {
+ target.path = $${INSTALL_PREFIX}/lib
+ }