summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD35
-rw-r--r--qotd-git.install14
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e8de42843f12
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Fri Feb 5 11:02:45 UTC 2016
+pkgbase = qotd-git
+ pkgdesc = A simple QOTD (quote of the day) daemon.
+ pkgver = 0.2.1_9_g6707be8.6707be8
+ pkgrel = 1
+ url = https://github.com/ammongit/qotd
+ install = qotd-git.install
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = gcc
+ provides = qotd
+ conflicts = qotd
+ source = git+https://github.com/ammongit/qotd.git
+ sha256sums = SKIP
+
+pkgname = qotd-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1220be16834a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Ammon Smith <ammon.i.smith@gmail.com>
+
+_pkgname=qotd
+pkgname=$_pkgname-git
+pkgver=0.3.0.f9827bb
+pkgrel=1
+pkgdesc="A simple QOTD (quote of the day) daemon."
+arch=('any')
+url="https://github.com/ammongit/$_pkgname"
+license=('GPL')
+depends=()
+makedepends=('git' 'gcc')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+options=()
+install="$pkgname.install"
+source=("git+https://github.com/ammongit/$_pkgname.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ _ver="$(git describe --tags | sed 's/-/_/g')"
+ printf '%s.%s' "${_ver:1}" "$(git describe --always)"
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ make DESTDIR="$pkgdir" install
+}
+
diff --git a/qotd-git.install b/qotd-git.install
new file mode 100644
index 000000000000..e8fa8fc7c06b
--- /dev/null
+++ b/qotd-git.install
@@ -0,0 +1,14 @@
+post_install() {
+ systemctl daemon-reload
+
+ echo 'Start the new systemd unit:'
+ echo 'sudo systemctl enable --now qotd.service'
+}
+
+post_upgrade() {
+ systemctl daemon-reload
+
+ echo 'Restart the qotd systemd unit:'
+ echo 'sudo systemctl restart qotd.service'
+}
+