summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD35
1 files changed, 28 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3805289851c7..af9f9276abd9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,37 @@
# Maintainer: Donald Carr <sirspudd at gmail dot com>
-_aarch64=false
+#set -x
+
+if [[ -z $_piver ]] && [[ -n $LOCAL_PI_VER ]]; then
+ _piver=$LOCAL_PI_VER
+fi
+
+if [[ -z $_piver ]]; then
+ echo "You have to specify a Raspberry Pi version before continuing"
+ exit 1
+fi
+
+if [[ -n "$_piver" ]]; then
+ _qmake="/opt/qt-sdk-raspberry-pi${_piver}/bin/qmake"
+fi
_pkgname=qpi
-_toolchainname=armv7-rpi2-linux-gnueabihf
-if $_aarch64; then
- _pkgname="$_pkgname-aarch64"
+
+case $_piver in
+1)
+ _toolchainname=armv6-rpi-linux-gnueabihf
+;;
+2)
+ _toolchainname=armv7-rpi2-linux-gnueabihf
+;;
+3)
_toolchainname=aarch64-rpi3-linux-gnueabi
-fi
-pkgname=${_pkgname}-toolchain
+;;
+esac
+
+pkgname=qpi${_piver}-toolchain
pkgver=6.1.0
-pkgrel=3
+pkgrel=4
pkgdesc="cross-tool-ng compiled GCC toolchain for the pi"
arch=("x86_64")
license=("GPL")