summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rwxr-xr-xPKGBUILD27
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..23693a30f34e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = qt-ads-git
+ pkgdesc = Qt Advanced Docking System lets you create customizable layouts using a full featured window docking system similar to what is found in many popular integrated development environments (IDEs) such as Visual Studio.
+ pkgver = 4.0.1
+ pkgrel = 1
+ url = https://github.com/githubuser0xFFFF/Qt-Advanced-Docking-System
+ arch = x86_64
+ license = LGPL2.1
+ depends = qt5-base
+ source = git+https://github.com/githubuser0xFFFF/Qt-Advanced-Docking-System
+ sha512sums = SKIP
+
+pkgname = qt-ads-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..54380a9d1add
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Evgenii Fedoseev
+
+pkgname=qt-ads-git
+pkgver=4.0.1
+pkgrel=1
+pkgdesc="Qt Advanced Docking System lets you create customizable layouts using a full featured window docking system similar to what is found in many popular integrated development environments (IDEs) such as Visual Studio."
+arch=('x86_64')
+url="https://github.com/githubuser0xFFFF/Qt-Advanced-Docking-System"
+depends=('qt5-base')
+license=("LGPL2.1")
+source=("git+https://github.com/githubuser0xFFFF/Qt-Advanced-Docking-System")
+sha512sums=('SKIP')
+
+build() {
+ cd "${srcdir}/Qt-Advanced-Docking-System"
+ ls
+ mkdir -p build
+ cd build
+ cmake ..
+ cmake --build . --config Release
+}
+
+package() {
+ cd "${srcdir}/Qt-Advanced-Docking-System/build"
+ cmake --install . --prefix ${pkgdir}/usr
+}
+