summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
-rw-r--r--qt-ponies-qt5.14.patch55
3 files changed, 65 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6c5df9a00ead..e77e09538161 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Sun Jul 2 15:35:12 UTC 2017
pkgbase = qt-ponies-git
pkgdesc = Desktop ponies in Qt
pkgver = v0.9.3.g882a8cf
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/myszha/qt-ponies
arch = i686
arch = x86_64
@@ -14,8 +12,10 @@ pkgbase = qt-ponies-git
provides = qt-ponies
source = git://github.com/myszha/qt-ponies.git
source = qt-ponies-qt5.patch
+ source = qt-ponies-qt5.14.patch
sha256sums = SKIP
sha256sums = 5681360eb583cd25d42200abda9c01c050db69778c63a8a2ab79b6ecbb441034
+ sha256sums = cb7019e0dd6bdbf335ffd52748cd60a58e1ef15e81974b4db58fb5bee1db5f88
pkgname = qt-ponies-git
diff --git a/PKGBUILD b/PKGBUILD
index d43205860253..d7bb2943c21c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
# Contributor: mid-kid <esteve.varela@gmail.com>
# based on https://github.com/aur-archive/qt-ponies-git/blob/master/PKGBUILD
_gitname="qt-ponies"
-pkgname="$_gitname-git"
+pkgname=qt-ponies-git
pkgver=v0.9.3.g882a8cf
-pkgrel=2
+pkgrel=3
pkgdesc="Desktop ponies in Qt"
arch=("i686" "x86_64")
url="https://github.com/myszha/qt-ponies"
@@ -15,9 +15,11 @@ provides=("qt-ponies")
source=(
"git://github.com/myszha/$_gitname.git"
"qt-ponies-qt5.patch"
+ "qt-ponies-qt5.14.patch"
)
sha256sums=('SKIP'
- '5681360eb583cd25d42200abda9c01c050db69778c63a8a2ab79b6ecbb441034')
+ '5681360eb583cd25d42200abda9c01c050db69778c63a8a2ab79b6ecbb441034'
+ 'cb7019e0dd6bdbf335ffd52748cd60a58e1ef15e81974b4db58fb5bee1db5f88')
pkgver() {
@@ -31,6 +33,8 @@ prepare() {
sed -i "s/.\/desktop-ponies/\/usr\/share\/qt-ponies\/desktop-ponies/g" src/configwindow.cpp
# Patch for Qt5 - big kudos to Kiwii for this :)
patch -p1 < "$srcdir/qt-ponies-qt5.patch"
+ # Patch for Qt5.14
+ patch -p1 < "$srcdir/qt-ponies-qt5.14.patch"
}
package() {
diff --git a/qt-ponies-qt5.14.patch b/qt-ponies-qt5.14.patch
new file mode 100644
index 000000000000..61fce0b40bef
--- /dev/null
+++ b/qt-ponies-qt5.14.patch
@@ -0,0 +1,55 @@
+commit 641da6a21ced8b1c1373aa1eb17a5667cdadbd58
+Author: Daniel Maslowski <info@orangecms.org>
+Date: Sun Oct 25 21:31:24 2020 +0100
+
+ remove redefinition of QString
+
+ This has been added in Qt 5.14. See also
+ https://github.com/linuxdeepin/deepin-system-monitor/issues/34#issuecomment-578397562
+
+diff --git a/src/csv_parser.cpp b/src/csv_parser.cpp
+index 154db8d..3421f9c 100644
+--- a/src/csv_parser.cpp
++++ b/src/csv_parser.cpp
+@@ -3,18 +3,6 @@
+
+ #include "csv_parser.h"
+
+-namespace std
+-{
+- template <>
+- struct hash<QString>
+- {
+- size_t operator()(const QString& s) const
+- {
+- return qHash(s);
+- }
+- };
+-}
+-
+ std::unordered_map<QString, const CSVParser::ParseTypes &> CSVParser::parse_types;
+
+ static QVariant convert_type(std::pair<std::string, QVariant::Type> type, QString value)
+diff --git a/src/pony.h b/src/pony.h
+index e6d4d92..ba35b40 100644
+--- a/src/pony.h
++++ b/src/pony.h
+@@ -38,18 +38,6 @@
+
+ class ConfigWindow;
+
+-namespace std
+-{
+- template <>
+- struct hash<QString>
+- {
+- size_t operator()(const QString& s) const
+- {
+- return qHash(s);
+- }
+- };
+-}
+-
+ class Pony : public QMainWindow, public std::enable_shared_from_this<Pony>
+ {
+ Q_OBJECT