aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD2
1 files changed, 2 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c300163b3954..3c4604fc0ca7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -199,8 +199,10 @@ if $_patching; then
cd ${_basedir}
patch -p1 < ${startdir}/0001-Check-lib64-as-well-as-lib.patch
+if [[ "${_piver}" = "3" ]]; then
cd ${_declarativedir}
patch -p1 < ${startdir}/0001-WIP-V4-Free-up-2-address-bits-in-64bit-mode.patch
+fi
# Work around our embarresing propensity to stomp on your own tailored build configuration
sed -i "s/O[23]/Os/" ${_basedir}/mkspecs/common/gcc-base.conf || exit 1