aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD16
1 files changed, 11 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e97b520c5b9c..3c3ba98ee758 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -164,7 +164,17 @@ _source_package_name=${_qt_package_name_prefix}-${_pkgver}
_baseprefix=/opt
_installprefix=${_baseprefix}/${pkgname}
-$_static_build || _additional_configure_flags="$_additional_configure_flags -hostprefix ${_installprefix}"
+if $_static_build; then
+ _additional_configure_flags="$_additional_configure_flags -no-ico"
+else
+ _additional_configure_flags="$_additional_configure_flags \
+ -hostprefix ${_installprefix} \
+ -fontconfig \
+ -system-sqlite \
+ -system-freetype \
+ -system-harfbuzz \
+ "
+fi
pkgdesc="Qt SDK for the Raspberry Pi 1/2/3"
arch=("x86_64")
@@ -197,10 +207,6 @@ _core_configure_options="\
-v \
-silent \
-release \
- -fontconfig \
- -system-sqlite \
- -system-freetype \
- -system-harfbuzz \
-pch \
-opengl es2 \
-egl \