aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--0001-Check-lib64-as-well-as-lib.patch46
-rw-r--r--0001-Move-qt-declarative-to-4c3246e49521b6341ddcc513814ae.patch.bz2bin50966 -> 0 bytes
-rw-r--r--0001-Put-xcomposite-config-test-on-a-leash.patch25
-rw-r--r--0001-Revert-Fully-qualify-libEGL.so.1-libEGLESv2.so.2-lib.patch33
-rw-r--r--PKGBUILD58
5 files changed, 8 insertions, 154 deletions
diff --git a/0001-Check-lib64-as-well-as-lib.patch b/0001-Check-lib64-as-well-as-lib.patch
deleted file mode 100644
index 41b2c2306a47..000000000000
--- a/0001-Check-lib64-as-well-as-lib.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-From 2586eaac76349843ed573e8e7c24761d343a8b42 Mon Sep 17 00:00:00 2001
-From: Donald Carr <sirspudd@gmail.com>
-Date: Sun, 11 Sep 2016 18:10:14 -0700
-Subject: [PATCH] Check lib64 as well as lib
-
-Change-Id: I3a875a215e8524e5b1f2d5222ef3134bc1aa719f
----
- configure.pri | 15 +++++++++++----
- 1 file changed, 11 insertions(+), 4 deletions(-)
-
-diff --git a/configure.pri b/configure.pri
-index 6a75398..2240dea 100644
---- a/configure.pri
-+++ b/configure.pri
-@@ -148,17 +148,24 @@ defineTest(qtConfTest_detectPkgConfig) {
- qtConfAddWarning("Cross compiling without sysroot. Disabling pkg-config")
- return(false)
- }
-- !exists("$$sysroot/usr/lib/pkgconfig") {
-+ exists("$$sysroot/usr/lib/pkgconfig") {
-+ pkgConfigLibdir = "$$pkgConfigLibdir:$$sysroot/usr/lib/pkgconfig"
-+ }
-+ exists("$$sysroot/usr/lib64/pkgconfig") {
-+ pkgConfigLibdir = "$$pkgConfigLibdir:$$sysroot/usr/lib64/pkgconfig"
-+ }
-+
-+ isEmpty(pkgConfigLibdir) {
- qtConfAddWarning( \
-- "Disabling pkg-config since PKG_CONFIG_LIBDIR is not set and" \
-- "the host's .pc files would be used (even if you set PKG_CONFIG_PATH)." \
-+ "Disabling pkg-config since PKG_CONFIG_LIBDIR is not set and cant be inferred." \
-+ "The host's .pc files would be used (even if you set PKG_CONFIG_PATH)." \
- "Set this variable to the directory that contains target .pc files" \
- "for pkg-config to function correctly when cross-compiling or" \
- "use -pkg-config to override this test.")
- return(false)
- }
-
-- pkgConfigLibdir = $$sysroot/usr/lib/pkgconfig:$$sysroot/usr/share/pkgconfig
-+ pkgConfigLibdir = "$$pkgConfigLibdir:$$sysroot/usr/share/pkgconfig"
- gcc {
- qtRunLoggedCommand("$$QMAKE_CXX -dumpmachine", gccMachineDump): \
- !isEmpty(gccMachineDump): \
---
-2.9.3
-
diff --git a/0001-Move-qt-declarative-to-4c3246e49521b6341ddcc513814ae.patch.bz2 b/0001-Move-qt-declarative-to-4c3246e49521b6341ddcc513814ae.patch.bz2
deleted file mode 100644
index 5e79198ba250..000000000000
--- a/0001-Move-qt-declarative-to-4c3246e49521b6341ddcc513814ae.patch.bz2
+++ /dev/null
Binary files differ
diff --git a/0001-Put-xcomposite-config-test-on-a-leash.patch b/0001-Put-xcomposite-config-test-on-a-leash.patch
deleted file mode 100644
index afdc6a8ed198..000000000000
--- a/0001-Put-xcomposite-config-test-on-a-leash.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 5e150e1682d4eb4f0f0cc04e545e19cbaf908369 Mon Sep 17 00:00:00 2001
-From: Donald Carr <d@chaos-reins.com>
-Date: Tue, 12 Sep 2017 22:54:43 -0700
-Subject: [PATCH] Put xcomposite config test on a leash
-
-Change-Id: Ifefa3209db0a249095f04cbe914aeed931c6c62a
----
- config.tests/xcomposite/main.cpp | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/config.tests/xcomposite/main.cpp b/config.tests/xcomposite/main.cpp
-index 11ba3b5a..4014d5e2 100644
---- a/config.tests/xcomposite/main.cpp
-+++ b/config.tests/xcomposite/main.cpp
-@@ -42,6 +42,7 @@
-
- int main (int argc, char **argv)
- {
-+ #error eat shit and die
- XCompositeRedirectWindow((Display *)0,(Window) 0,CompositeRedirectManual);
-
- return 0;
---
-2.14.1
-
diff --git a/0001-Revert-Fully-qualify-libEGL.so.1-libEGLESv2.so.2-lib.patch b/0001-Revert-Fully-qualify-libEGL.so.1-libEGLESv2.so.2-lib.patch
deleted file mode 100644
index 4ffa2a9c6135..000000000000
--- a/0001-Revert-Fully-qualify-libEGL.so.1-libEGLESv2.so.2-lib.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From c33f6dffee64bdb77321d9d21dd6b520271593b0 Mon Sep 17 00:00:00 2001
-From: Donald Carr <sirspudd@gmail.com>
-Date: Mon, 30 Jan 2017 23:49:28 -0800
-Subject: [PATCH] Revert "Fully qualify libEGL.so.1, libEGLESv2.so.2 libraries"
-
-This reverts commit d07fba149ddc6df4cbc99d31b1edb17331fcfe53.
----
- src/core/surface_factory_qt.cpp | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/core/surface_factory_qt.cpp b/src/core/surface_factory_qt.cpp
-index 97a30473..11d8f3b2 100644
---- a/src/core/surface_factory_qt.cpp
-+++ b/src/core/surface_factory_qt.cpp
-@@ -74,13 +74,13 @@ base::NativeLibrary LoadLibrary(const base::FilePath& filename) {
- bool SurfaceFactoryQt::LoadEGLGLES2Bindings(AddGLLibraryCallback add_gl_library, SetGLGetProcAddressProcCallback set_gl_get_proc_address)
- {
- base::FilePath libEGLPath = QtWebEngineCore::toFilePath(QT_LIBDIR_EGL);
-- libEGLPath = libEGLPath.Append("libEGL.so.1");
-+ libEGLPath = libEGLPath.Append("libEGL.so");
- base::NativeLibrary eglLibrary = LoadLibrary(libEGLPath);
- if (!eglLibrary)
- return false;
-
- base::FilePath libGLES2Path = QtWebEngineCore::toFilePath(QT_LIBDIR_GLES2);
-- libGLES2Path = libGLES2Path.Append("libGLESv2.so.2");
-+ libGLES2Path = libGLES2Path.Append("libGLESv2.so");
- base::NativeLibrary gles2Library = LoadLibrary(libGLES2Path);
- if (!gles2Library)
- return false;
---
-2.11.0
-
diff --git a/PKGBUILD b/PKGBUILD
index d6422bee3715..b95df8e046bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -88,11 +88,11 @@ if $_testing; then
_dev_suffix="beta3"
pkgrel=3
else
- _pkgvermajmin="5.9"
- _pkgverpatch=".1"
+ _pkgvermajmin="5.10"
+ _pkgverpatch=".0"
# {alpha/beta/beta2/rc}
_dev_suffix=""
- pkgrel=5
+ pkgrel=4
fi
pkgver="${_pkgvermajmin}${_pkgverpatch}"
$_build_from_head && pkgver=6.6.6
@@ -184,16 +184,11 @@ $_debug && _additional_configure_flags="$_additional_configure_flags -force-debu
_libspkgname="${pkgname}-target-libs"
_libsdebugpkgname="${pkgname}-target-libs-debug"
_packaginguser=$(whoami)
-if $_testing; then
- _qt_package_name_prefix="qt-everywhere-src"
- _source_package_name=${_qt_package_name_prefix}-${_pkgver}
-else
- _qt_package_name_prefix="qt-everywhere-opensource-src"
- if [[ -n ${_dev_suffix} ]]; then
+_qt_package_name_prefix="qt-everywhere-src"
+if [[ -n ${_dev_suffix} ]]; then
_pkgver=${pkgver}-${_dev_suffix}
- fi
- _source_package_name=${_qt_package_name_prefix}-${_pkgver}
fi
+_source_package_name=${_qt_package_name_prefix}-${_pkgver}
_baseprefix=/opt
_installprefix=${_baseprefix}/${pkgname}
@@ -316,20 +311,14 @@ _core_configure_options="\
\
-reduce-exports"
-if ! $_testing; then
- _core_configure_options="\
- $_core_configure_options \
- -reduce-relocations"
-fi
-
if $_testing; then
_tar_xz_sha256="7139adf57f703761fd4cac29bf6ee81a10b93c1fa11e5643d4c98e1367e20972"
else
- _tar_xz_sha256="7b41a37d4fe5e120cdb7114862c0153f86c07abbec8db71500443d2ce0c89795"
+ _tar_xz_sha256="936d4cf5d577298f4f9fdb220e85b008ae321554a5fcd38072dc327a7296230e"
fi
if ! $_build_from_head; then
- source=("git://github.com/sirspudd/mkspecs.git" "${_provider}/${_release_type}/qt/${_pkgvermajmin}/${pkgver}-${_dev_suffix}/single/${_source_package_name}.tar.xz")
+ source=("git://github.com/sirspudd/mkspecs.git" "${_provider}/${_release_type}/qt/${_pkgvermajmin}/${_pkgver}/single/${_source_package_name}.tar.xz")
sha256sums=("SKIP" "$_tar_xz_sha256")
fi
@@ -409,37 +398,6 @@ if ! $_target_host; then
cp -r "${srcdir}/mkspecs/${_mkspec}" $_mkspec_dir
fi
-if $_patching; then
- # build qtwebengine with our mkspec
-
-if ! $_testing; then
- echo "INCLUDEPATH += ${_sysroot}/usr/include/openssl-1.0" >> ${_basedir}/src/network/network.pro
- # hard coded off, so we have to hard code it on
- local _reducerelocations="${_basedir}/config.tests/unix/reduce_relocs/bsymbolic_functions.c"
- sed -i "s/error/warning/" ${_reducerelocations} || exit 1
-fi
-
- cd ${_basedir}
- #patch -p1 < ${startdir}/0001-Check-lib64-as-well-as-lib.patch
-
-if ! $_testing; then
- cd ${_declarativedir}
- bunzip2 ${startdir}/0001-Move-qt-declarative-to-4c3246e49521b6341ddcc513814ae.patch.bz2 -c > ${startdir}/0001-Move-qt-declarative-to-4c3246e49521b6341ddcc513814ae.patch
- patch -p1 < ${startdir}/0001-Move-qt-declarative-to-4c3246e49521b6341ddcc513814ae.patch
-fi
- #patch -p1 < ${startdir}/0001-Fix-crash-in-QQuickPixmapReader-friends.patch
- #patch -p1 < ${startdir}/0001-Fix-build-with-qreal-as-float.patch
-
- cd ${_waylanddir}
- patch -p1 < ${startdir}/0001-Put-xcomposite-config-test-on-a-leash.patch
- #patch -p1 < ${startdir}/0001-Fix-brcm-egl-build-by-correcting-commit-usage.patch
- #patch -p1 < ${startdir}/0001-Avoid-double-deletion-of-mBuffer.patch
-
- #cd ${_webenginedir}
- # reverse patch which breaks dynamic loading of EGL/GLESvs with rpi proprietary drivers
- #patch -p1 < ${startdir}/0001-Revert-Fully-qualify-libEGL.so.1-libEGLESv2.so.2-lib.patch
-fi
-
rm -Rf ${_bindir}
mkdir -p ${_bindir}
cd ${_bindir}