summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD34
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a83bf4e5f48f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = qt5-gtkplatform-git
+ pkgdesc = Run Qt applications using GTK+ as a windowing system
+ pkgver = 0.2.4.r11.g1149f4f
+ pkgrel = 1
+ url = https://github.com/CrimsonAS/gtkplatform
+ arch = x86_64
+ license = GPL2
+ license = GPL3
+ license = LGPL3
+ license = custom
+ makedepends = make
+ depends = qt5-base
+ depends = gtk3
+ depends = libnotify
+ provides = qt5-gtkplatform
+ conflicts = qt5-gtkplatform
+ source = qt5-gtkplatform::git+https://github.com/CrimsonAS/gtkplatform.git
+ sha256sums = SKIP
+
+pkgname = qt5-gtkplatform-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..689a5b747402
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Davide Depau <davide@depau.eu>
+
+_pkgname=qt5-gtkplatform
+pkgname=$_pkgname-git
+pkgver=0.2.4.r11.g1149f4f
+pkgrel=1
+pkgdesc="Run Qt applications using GTK+ as a windowing system"
+arch=('x86_64')
+depends=('qt5-base' 'gtk3' 'libnotify')
+makedepends=('make')
+url="https://github.com/CrimsonAS/gtkplatform"
+license=('GPL2' 'GPL3' 'LGPL3' 'custom')
+source=(${_pkgname}::git+https://github.com/CrimsonAS/gtkplatform.git)
+sha256sums=('SKIP')
+provides=($_pkgname)
+conflicts=($_pkgname)
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/${_pkgname}"
+ qmake
+ make
+}
+
+package() {
+ cd "$srcdir/${_pkgname}"
+ make INSTALL_ROOT="$pkgdir/" DESTDIR="$pkgdir" install
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}