summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--0001-Enable-high-dpi-on-Linux.patch27
-rw-r--r--PKGBUILD10
-rw-r--r--qtcreator-prerelease.install36
4 files changed, 46 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2e59e6f52945..4927530a1d5f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Mar 28 05:34:15 UTC 2018
+# Wed Jun 6 23:34:03 UTC 2018
pkgbase = qtcreator-prerelease
pkgdesc = Qt Creator prerelease/latest
- pkgver = 4.6.0
- pkgrel = 3
+ pkgver = 4.7.0
+ pkgrel = 1
url = http://qt.io/ide
arch = x86_64
license = GPL
@@ -34,8 +34,8 @@ pkgbase = qtcreator-prerelease
provides = qbs
conflicts = qtcreator
conflicts = qbs
- source = https://download.qt.io/development_releases/qtcreator/4.6/4.6.0-rc1/qt-creator-opensource-src-4.6.0-rc1.tar.xz
- sha256sums = ce6225b2d5283fbd0c96c000952d247ecd9a537038375914374952f78b215e9d
+ source = https://download.qt.io/development_releases/qtcreator/4.7/4.7.0-beta1/qt-creator-opensource-src-4.7.0-beta1.tar.xz
+ sha256sums = 1b4964a59c01ed4401af420be49bda0aa2a8292c893a1f22e2204dea3f6bcd74
pkgname = qtcreator-prerelease
diff --git a/0001-Enable-high-dpi-on-Linux.patch b/0001-Enable-high-dpi-on-Linux.patch
deleted file mode 100644
index 551235fb575d..000000000000
--- a/0001-Enable-high-dpi-on-Linux.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From edd624f6b889fbfc8bb7d83ee122b73f9ca2c95f Mon Sep 17 00:00:00 2001
-From: Donald Carr <d@chaos-reins.com>
-Date: Tue, 12 Dec 2017 09:12:49 -0800
-Subject: [PATCH] Enable high dpi on Linux
-
-Change-Id: Ib2e93e386acb23c27f1542a939a29e21d8c56d8c
----
- src/app/main.cpp | 2 +-
- src/shared/qbs | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/app/main.cpp b/src/app/main.cpp
-index fa6e93ef8e..06c3c48633 100644
---- a/src/app/main.cpp
-+++ b/src/app/main.cpp
-@@ -159,7 +159,7 @@ static inline int askMsgSendFailed()
- static void setHighDpiEnvironmentVariable()
- {
- static const char ENV_VAR_QT_DEVICE_PIXEL_RATIO[] = "QT_DEVICE_PIXEL_RATIO";
-- if (Utils::HostOsInfo().isWindowsHost()
-+ if (!Utils::HostOsInfo().isMacHost()
- && !qEnvironmentVariableIsSet(ENV_VAR_QT_DEVICE_PIXEL_RATIO) // legacy in 5.6, but still functional
- && !qEnvironmentVariableIsSet("QT_AUTO_SCREEN_SCALE_FACTOR")
- && !qEnvironmentVariableIsSet("QT_SCALE_FACTOR")
---
-2.15.1
-
diff --git a/PKGBUILD b/PKGBUILD
index 39a3759fe1e0..6fb150f13a09 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,10 +7,10 @@
#_qmake_args="CONFIG+=debug"
_building=true
pkgname=qtcreator-prerelease
-_pkgvermajmin=4.6
+_pkgvermajmin=4.7
pkgver=${_pkgvermajmin}.0
-_verpostfix=""
-pkgrel=4
+_verpostfix="beta1"
+pkgrel=1
_pkgver=${pkgver}
_urlbase="https://download.qt.io/official_releases"
if [[ -n $_verpostfix ]]; then
@@ -25,6 +25,7 @@ license=('GPL')
provides=('qtcreator' 'qbs')
conflicts=('qtcreator' 'qbs')
depends=('python2-beautifulsoup4' 'qt5-tools' 'qt5-declarative' 'qt5-script' 'qt5-quickcontrols' 'qt5-quickcontrols2' 'qt5-webengine' 'clang' 'llvm')
+install=qtcreator-prerelease.install
optdepends=('qbs'
'qt5-doc: integrated Qt documentation'
'qt5-examples: welcome page examples'
@@ -38,7 +39,7 @@ optdepends=('qbs'
'valgrind: analyze support')
makedepends=('qbs' 'clang' 'qt5-base')
source=("${_urlbase}/qtcreator/${_pkgvermajmin}/${_pkgver}/${_filename}.tar.xz")
-sha256sums=('36e6a9146fbd07f045ea19301176c66f8234afd42bae0a7a17c91e1832fc4882')
+sha256sums=('1b4964a59c01ed4401af420be49bda0aa2a8292c893a1f22e2204dea3f6bcd74')
_qmake_cmd=qmake
_tmp_dir=$(mktemp -d)
@@ -53,7 +54,6 @@ fi
prepare() {
cd ${srcdir}/${_filename}
sed -i '/LLVM_INCLUDEPATH/d' src/tools/clangbackend/clangbackend.pro
- patch -p1 < ${startdir}/0001-Enable-high-dpi-on-Linux.patch
}
build() {
diff --git a/qtcreator-prerelease.install b/qtcreator-prerelease.install
new file mode 100644
index 000000000000..87ad578c659a
--- /dev/null
+++ b/qtcreator-prerelease.install
@@ -0,0 +1,36 @@
+## arg 1: the new package version
+pre_install() {
+ echo ""
+}
+
+## arg 1: the new package version
+post_install() {
+ echo ""
+ echo "High DPI scaling is disabled by default upstream"
+ echo "This can be overridden by setting Core/EnableHighDpiScaling to true in your QtCreator settings"
+ echo ""
+}
+#post_install
+
+## arg 1: the new package version
+## arg 2: the old package version
+pre_upgrade() {
+ echo ""
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+post_upgrade() {
+ echo ""
+}
+
+## arg 1: the old package version
+pre_remove() {
+ echo ""
+}
+#pre_remove
+
+## arg 1: the old package version
+post_remove() {
+ echo ""
+}