summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--0001-Remove-plethora-of-Qt-Creator-platform-hacks.patch42
-rw-r--r--PKGBUILD5
2 files changed, 47 insertions, 0 deletions
diff --git a/0001-Remove-plethora-of-Qt-Creator-platform-hacks.patch b/0001-Remove-plethora-of-Qt-Creator-platform-hacks.patch
new file mode 100644
index 000000000000..bd70af198655
--- /dev/null
+++ b/0001-Remove-plethora-of-Qt-Creator-platform-hacks.patch
@@ -0,0 +1,42 @@
+From 984086a4b544991fb6e9b32fc992c8000793086d Mon Sep 17 00:00:00 2001
+From: Donald Carr <d@chaos-reins.com>
+Date: Tue, 26 Sep 2017 12:51:06 -0700
+Subject: [PATCH] Remove plethora of Qt Creator platform hacks
+
+Change-Id: If147e62c63a326e5316f3f7ba22f8790ca8c66f6
+---
+ src/app/main.cpp | 10 ----------
+ 1 file changed, 10 deletions(-)
+
+diff --git a/src/app/main.cpp b/src/app/main.cpp
+index 7235796e3f..fbf5166c46 100644
+--- a/src/app/main.cpp
++++ b/src/app/main.cpp
+@@ -158,14 +158,7 @@ static inline int askMsgSendFailed()
+
+ static void setHighDpiEnvironmentVariable()
+ {
+- static const char ENV_VAR_QT_DEVICE_PIXEL_RATIO[] = "QT_DEVICE_PIXEL_RATIO";
+- if (Utils::HostOsInfo().isWindowsHost()
+- && !qEnvironmentVariableIsSet(ENV_VAR_QT_DEVICE_PIXEL_RATIO) // legacy in 5.6, but still functional
+- && !qEnvironmentVariableIsSet("QT_AUTO_SCREEN_SCALE_FACTOR")
+- && !qEnvironmentVariableIsSet("QT_SCALE_FACTOR")
+- && !qEnvironmentVariableIsSet("QT_SCREEN_SCALE_FACTORS")) {
+ QCoreApplication::setAttribute(Qt::AA_EnableHighDpiScaling);
+- }
+ }
+
+ // taken from utils/fileutils.cpp. We can not use utils here since that depends app_version.h.
+@@ -298,9 +291,6 @@ void loadFonts()
+
+ int main(int argc, char **argv)
+ {
+- if (Utils::HostOsInfo::isLinuxHost())
+- QApplication::setAttribute(Qt::AA_DontUseNativeMenuBar);
+-
+ Utils::TemporaryDirectory::setMasterTemporaryDirectory(QDir::tempPath() + "/" + Core::Constants::IDE_CASED_ID + "-XXXXXX");
+
+ setHighDpiEnvironmentVariable();
+--
+2.14.1
+
diff --git a/PKGBUILD b/PKGBUILD
index 81a86441fa9b..8e0b4c564cd1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -50,6 +50,11 @@ if [[ -z ${startdir} ]]; then
_building=false
fi
+prepare() {
+ cd ${srcdir}/${_filename}
+ patch -p1 < ${startdir}/0001-Remove-Qt-Creator-making-several-hostile-platform-as.patch
+}
+
build() {
set -o nounset
local src_dir=${srcdir}/${_filename}