summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD37
2 files changed, 27 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 229ccce496f2..0fc74b26ecb1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = qtcreator-spellchecker-plugin-git
pkgdesc = Spell Checker plugin for the Qt Creator IDE
- pkgver = 3.4.0.r2.g83277fc
+ pkgver = 3.6.0.r0.g5460316
pkgrel = 1
url = https://github.com/CJCombrink/SpellChecker-Plugin
- arch = i686
arch = x86_64
groups = qt
- license = LGPL3
- license = GPL3
+ license = LGPL-3.0-only
+ license = GPL-3.0-only
makedepends = git
makedepends = cmake
makedepends = qtcreator-devel
@@ -15,8 +14,7 @@ pkgbase = qtcreator-spellchecker-plugin-git
depends = hunspell
provides = qtcreator-spellchecker-plugin
conflicts = qtcreator-spellchecker-plugin
- conflicts = qtcreator-spellchecker-plugin-bin
- source = qtcreator-spellchecker-plugin-git::git+https://github.com/CJCombrink/SpellChecker-Plugin.git
+ source = qtcreator-spellchecker-plugin::git+https://github.com/CJCombrink/SpellChecker-Plugin.git
sha256sums = SKIP
pkgname = qtcreator-spellchecker-plugin-git
diff --git a/PKGBUILD b/PKGBUILD
index 62054f7bba92..9ea73710e77f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,42 @@
-# Submitter: Rodrigo Bezerra <rodrigobezerra21 at gmail dot com>
+# Contributor: Rodrigo Bezerra <rodrigobezerra21 at gmail dot com>
# Maintainer: TheBill2001 <tuantran1632001 at gmail dot com>
-pkgname=qtcreator-spellchecker-plugin-git
-pkgver=3.4.0.r2.g83277fc
+_pkgname=qtcreator-spellchecker-plugin
+pkgname=${_pkgname}-git
+pkgver=3.6.0.r0.g5460316
pkgrel=1
pkgdesc="Spell Checker plugin for the Qt Creator IDE"
groups=('qt')
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="https://github.com/CJCombrink/SpellChecker-Plugin"
-license=('LGPL3' 'GPL3')
-depends=('qtcreator' 'hunspell')
+license=('LGPL-3.0-only' 'GPL-3.0-only')
+depends=(
+ 'qtcreator'
+ 'hunspell'
+)
+makedepends=(
+ 'git'
+ 'cmake'
+ 'qtcreator-devel'
+)
provides=('qtcreator-spellchecker-plugin')
-conflicts=('qtcreator-spellchecker-plugin' 'qtcreator-spellchecker-plugin-bin')
-makedepends=('git' 'cmake' 'qtcreator-devel')
-source=("$pkgname"::git+${url}.git)
+conflicts=('qtcreator-spellchecker-plugin')
+source=("${_pkgname}::git+${url}.git")
sha256sums=('SKIP')
pkgver() {
- cd "${pkgname}"
+ cd "${_pkgname}"
git describe --long --tags --abbrev=7 | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
cmake \
- -S ${pkgname}\
+ -S "${_pkgname}"\
-B build \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DQT_DIR=/usr/lib/cmake/Qt6
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DCMAKE_PREFIX_PATH="/usr/lib/cmake/Qt6" \
+ -Wno-dev
cmake --build build
}