summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD34
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5a409e76f49c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = qtraw-git
+ pkgdesc = Qt image plugin for loading raw files, via libraw
+ pkgver = 1.1.r32
+ pkgrel = 1
+ url = https://gitlab.com/mardy/qtraw
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = qt5-base
+ depends = libraw
+ source = qtraw::git+https://gitlab.com/mardy/qtraw
+ sha256sums = SKIP
+
+pkgname = qtraw-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..96eb0f2ac51b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.gitignore
+!.SRCINFO \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2e2643d1813f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Stephanie Hobbs (RX14) <steph@rx14.co.uk>
+
+pkgname=qtraw-git
+pkgver=1.1.r32
+pkgrel=1
+pkgdesc="Qt image plugin for loading raw files, via libraw"
+arch=('x86_64')
+url="https://gitlab.com/mardy/qtraw"
+license=('GPL3')
+depends=("qt5-base" "libraw")
+makedepends=('git')
+source=("qtraw::git+https://gitlab.com/mardy/qtraw")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd qtraw
+
+ local project_version="$(sed -n 's/PROJECT_VERSION = \(.*\)$/\1/ p' common-config.pri)"
+ printf "%s.r%s" "$project_version" "$(git rev-list --count HEAD)"
+}
+
+build() {
+ cd qtraw
+
+ qmake PREFIX="/usr"
+ make
+}
+
+package() {
+ cd qtraw
+
+ make install INSTALL_ROOT="$pkgdir"
+ rm -Rf "$pkgdir/usr/share/kde4"
+}