summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD18
2 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 90eacc90a26d..62f7b33324ca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Thu Mar 17 17:02:00 UTC 2016
pkgbase = quake3-edawn
pkgdesc = A Quake III Arena mod with numerous improvements
pkgver = 1.4.1
- pkgrel = 1
+ pkgrel = 2
url = http://edawn-mod.org/
arch = any
license = custom
diff --git a/PKGBUILD b/PKGBUILD
index a417f2c8f890..d5e1e319c08c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,28 +2,28 @@
pkgname=quake3-edawn
pkgver=1.4.1
-pkgrel=1
+pkgrel=2
pkgdesc="A Quake III Arena mod with numerous improvements"
arch=('any')
url="http://edawn-mod.org/"
license=('custom')
depends=('quake3')
-source=("http://edawn-mod.org/binaries/edawn-$pkgver-1.zip")
+source=("http://edawn-mod.org/binaries/edawn-${pkgver}-1.zip")
sha256sums=('a6a232f64fcfd3f6387d809b8a7912d6095b6dcd39cc6572407a54c96ab68a27')
package() {
- # Engines other than quake3e may have problems loading files
- # without the .cfg extension
+ # Non-modified Quake 3 engines may have problems loading
+ # files with unusual extensions
cd edawn
- for f in {bans,crontab,motd,rotation,voteconf}.txt maps/*.{add,set} ; do
+ for f in maps/*.{add,set}; do
mv "$f" "$f.cfg"
done
- cd "$srcdir"
- mkdir -p "$pkgdir/opt/quake3"
- cp -dR edawn "$pkgdir/opt/quake3"
+ cd "${srcdir}"
+ mkdir -p "${pkgdir}/opt/quake3"
+ cp -dR edawn "${pkgdir}/opt/quake3"
- install -D -m 644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -D -m 644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
# vim:set ts=2 sw=2 et: