summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD58
-rwxr-xr-xbatchInstall.sh142
-rw-r--r--questasim.desktop9
-rw-r--r--questasim.pngbin0 -> 14005 bytes
5 files changed, 227 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..78e19534899c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = questasim
+ pkgdesc = The Questa advanced simulator is the core simulation and debug engine of the Questa verification solution.
+ pkgver = 2022.4
+ pkgrel = 1
+ url = https://eda.sw.siemens.com/en-US/ic/questa/simulation/advanced-simulator/
+ arch = x86_64
+ license = proprietary
+ depends = freetype2
+ source = file://questa_sim-2022.4.aol
+ source = batchInstall.sh
+ source = questasim.png
+ source = questasim.desktop
+ md5sums = 496e550fac5cd7579c8dabc19081fd5c
+ md5sums = SKIP
+ md5sums = 5e23c736187b6ae30cc93cc8d03f4bd1
+ md5sums = 5f29fd57a8e52fd14d901ff36e918c0b
+
+pkgname = questasim
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..464f7f5c2d9e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Markus Koch <markus@notsyncing.net>
+
+# BUILD INSTRUCTIONS:
+#
+# 1. Download and copy questa_sim-2022.4.aol to the same directory as the PKGBUILD.
+# 2. [optional] Edit the end of `batchInstall.sh` to select product features.
+# Default: Only the QuestaSim simulator for VHDL + (System) Verilog.
+# 3. Run `makepkg`.
+
+pkgname=questasim
+pkgver=2022.4
+pkgrel=1
+pkgdesc="The Questa advanced simulator is the core simulation and debug engine of the Questa verification solution."
+arch=('x86_64')
+url="https://eda.sw.siemens.com/en-US/ic/questa/simulation/advanced-simulator/"
+license=('proprietary')
+groups=()
+depends=(freetype2)
+makedepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("file://questa_sim-2022.4.aol" batchInstall.sh questasim.png questasim.desktop)
+noextract=()
+md5sums=('496e550fac5cd7579c8dabc19081fd5c'
+ 'SKIP'
+ '5e23c736187b6ae30cc93cc8d03f4bd1'
+ '5f29fd57a8e52fd14d901ff36e918c0b')
+
+build() {
+ cd "$srcdir"
+}
+
+bin_symlink() {
+ for prog in "$@"; do
+ ln -s /opt/questasim/linux_x86_64/$prog $pkgdir/usr/bin/$prog
+ done
+}
+
+package() {
+ cd "$srcdir"
+ ./batchInstall.sh -tgt $pkgdir/opt
+ rm -rf $pkgdir/opt/_msidata
+
+ # link important binaries to /usr/bin/
+ mkdir -p $pkgdir/usr/bin/
+ bin_symlink vsim vcom vopt vlog vish vdel vmap xml2ucdb wlfrecover vdbg verror vencrypt voptclassic voptk vgencomp voptk2 mc2voptk2 vhencrypt vovl vcd2wlf vsimk vlm vmake vdbgpa
+
+ # install .desktop
+ install -D $srcdir/questasim.png $pkgdir/opt/questasim/questasim.png
+ install -D $srcdir/questasim.desktop $pkgdir/usr/share/applications/questasim.desktop
+}
+
diff --git a/batchInstall.sh b/batchInstall.sh
new file mode 100755
index 000000000000..abb939d1e2e5
--- /dev/null
+++ b/batchInstall.sh
@@ -0,0 +1,142 @@
+#!/bin/bash
+export LC_ALL=en_
+# ***************************************************************************************
+# *** This file is provided as-is. Modifications to this file are at your own risk. ***
+# *** The End User License Agreement was accepted during the creation of this script ***
+# *** by the user: root
+# ***************************************************************************************
+# Generated by MIP v6.2-026
+PROMPT_TARG="F"
+MIPPATH="./questa_sim-2022.4.aol"
+export MG_INSTALL_PID=`uname -n`-`date +%H.%M.%S`${RANDOM}
+if [ "$HOME" = "" ]; then
+ echo HOME env variable is not set. Please set it to your home directory.
+ exit 1
+fi
+if [[ ! -d "$HOME" ]]; then
+ echo HOME does not resolve to a valid directory.
+ exit 1
+fi
+MIP_PATH_ERRORS=0
+MIP_START_DIR=$HOME/mgc/$(basename "$MIPPATH")
+NEWTARG=
+NEWSRC=
+NEWMIPLOC=
+NEWDOCLOC=
+SELF=`dirname "$(readlink -f $0)"`
+SELF=$SELF/$(basename $0)
+MIPBATCMD="-batch"
+MIPBATPATH=`echo "$SELF"`
+MIPSKIP=
+MIPEXTRAARGS=
+MIPTARG="/opt/questa"
+MIPSRC="./questa_sim-2022.4.aol"
+while [ $# -gt 0 ];
+do
+ if [ "$1" = "-tgt" ]; then
+ shift
+ NEWTARG=`echo -tgt \'"$1"\'`
+ PROMPT_TARG=F
+ elif [ "$1" = "-src" ]; then
+ shift
+ NEWSRC=`echo -src \'"$1"\'`
+ elif [ "$1" = "-accesspath" ]; then
+ shift
+ NEWDOCLOC=`echo -accesspath \'"$1"\'`
+ elif [ "$1" = "-msiloc" ]; then
+ shift
+ NEWMIPLOC=`echo -msiloc "$1"`
+ MIP_START_DIR="$1"
+ elif [ "$1" = "-batchremove" ]; then
+ MIPBATCMD=`echo -block $1`
+ MIPSKIP="T"
+ elif [ "$1" = "-batchverify" ]; then
+ MIPBATCMD=`echo -block $1`
+ MIPSKIP="T"
+ elif [ "$1" = "-repair" ]; then
+ EXTRAARGS=`echo $EXTRAARGS "$1"`
+ elif [ "$1" = "-nojw" ]; then
+ EXTRAARGS=`echo $EXTRAARGS "$1"`
+ elif [ "$1" = "-deleteUserModifiedFiles" ]; then
+ EXTRAARGS=`echo $EXTRAARGS "$1"`
+ elif [ "$1" = "-batchall" ]; then
+ MIPBATCMD=`echo $1 -tgt "$MIPTARG"`
+ MIPBATPATH=`echo -src "$MIPSRC"`
+ elif [ "$1" = "-batchlicensed" ]; then
+ MIPBATCMD=`echo $1 -tgt "$MIPTARG"`
+ MIPBATPATH=`echo -src "$MIPSRC"`
+ elif [ "$1" = "-batchupdate" ]; then
+ MIPBATCMD=`echo $1 -tgt "$MIPTARG"`
+ MIPBATPATH=`echo -src "$MIPSRC"`
+ else
+ echo "USAGE: $0 [-tgt <target>] [-src <source>] [-msiloc <path>] [-batchremove] [-repair]"
+ exit 1
+ fi
+ shift
+done
+while [ ! -f "$MIPPATH" ];
+do
+ if [ "$MIPPATH" = "x" ]; then
+ exit
+ fi
+ MIP_PATH_ERRORS=$((MIP_PATH_ERRORS + 1))
+ if [ "$MIP_PATH_ERRORS" -gt 9 ]; then
+ exit 1
+ fi
+ echo "Could not find MIPPATH of: '$MIPPATH'"
+ echo "Enter path to install.* (or 'x' to quit): "
+ read MIPPATH
+done
+if [ "$PROMPT_TARG" = "T" ]; then
+ echo "Enter a Target Directory: "
+ read ENTERED_TARG
+ ENTERED_TARG=`echo $ENTERED_TARG | sed 's/"//g'`
+ NEWTARG=`echo -tgt \'"$ENTERED_TARG"\'`
+fi
+if [ ! "$MIPSKIP" = "T" ]; then
+ :
+# *** ADD YOUR OWN PRE INSTALL COMMANDS BELOW HERE ***
+
+
+# *** ADD YOUR OWN PRE INSTALL COMMANDS ABOVE HERE ***
+fi
+"$MIPPATH" $MIPBATCMD "$MIPBATPATH" $NEWTARG $NEWSRC $NEWDOCLOC $NEWMIPLOC $EXTRAARGS <<!!
+d
+yes
+!!
+INSTALLEXIT=$?
+if [ ! "$MIPSKIP" = "T" ]; then
+ :
+#
+fi
+if [ ! "$MIPSKIP" = "T" ]; then
+ :
+# *** ADD YOUR OWN POST INSTALL COMMANDS BELOW HERE ***
+
+
+# *** ADD YOUR OWN POST INSTALL COMMANDS ABOVE HERE ***
+fi
+LASTEXIT=$?
+if [ $INSTALLEXIT -ne 0 ]; then
+ exit $INSTALLEXIT
+fi
+exit $LASTEXIT
+
+##### BELOW HERE IS XML DATA #####
+
+<batchFile>
+ <source value="./questa_sim-2022.4.aol"/>
+ <target value="/opt/questa"/>
+ <installType value="all"/>
+ <platform value="Linux Opteron"/>
+ <release name="2022.4">
+ <!-- <product name="GCC 32-bit" productroot="questa_sim-base"/> -->
+ <!-- <product name="GCC 64-bit" productroot="questa_sim-base"/> -->
+ <!-- <product name="GCC ARM 64-bit" productroot="questa_sim-base"/> -->
+ <!-- <product name="Questa SIM 32-bit" productroot="questa_sim-base"/> -->
+ <product name="Questa SIM 64-bit" productroot="questa_sim-base"/>
+ <!-- <product name="Questa SIM ARM 64-bit" productroot="questa_sim-base"/> -->
+ <!-- <product name="Questa SIM Documentation" productroot="questa_sim-base"/> -->
+ <!-- <product name="Register Assistant" productroot="questa_sim-base"/> -->
+ </release>
+</batchFile>
diff --git a/questasim.desktop b/questasim.desktop
new file mode 100644
index 000000000000..d10e80a6a154
--- /dev/null
+++ b/questasim.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=QuestaSim
+Comment=The Questa advanced simulator is the core simulation and debug engine of the Questa verification solution
+Keywords=questa,model,modelsim,siemens,mentor
+Exec=vsim -gui -l /dev/null
+Icon=/opt/questasim/questasim.png
+Terminal=false
+Type=Application
+Categories=Development
diff --git a/questasim.png b/questasim.png
new file mode 100644
index 000000000000..6065473ca7c5
--- /dev/null
+++ b/questasim.png
Binary files differ