summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
-rw-r--r--gcc6-fix.patch31
3 files changed, 48 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 445bce9a14e3..5eb7224e4173 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon Jul 18 01:55:46 UTC 2016
+# Wed Feb 1 23:08:37 UTC 2017
pkgbase = quickrdp
pkgdesc = Connection manager program for your remote desktop, telnet, SSH or VNC connections.
pkgver = 2.4.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/arnestig/quickrdp
arch = i686
arch = x86_64
@@ -12,7 +12,9 @@ pkgbase = quickrdp
depends = curl
optdepends = rdesktop: remote desktop support
source = quickrdp-2.4.3.tar.gz::https://github.com/arnestig/quickrdp/archive/2.4.3.tar.gz
+ source = gcc6-fix.patch
md5sums = e9d7c6863c2081f0a4dab43712a6fccb
+ md5sums = acdd61e400a0f089ebe08ad8ae29580b
pkgname = quickrdp
diff --git a/PKGBUILD b/PKGBUILD
index 5a84d02c25ea..bf1942c839f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,28 @@
pkgname=quickrdp
pkgver=2.4.3
-pkgrel=1
+pkgrel=2
pkgdesc="Connection manager program for your remote desktop, telnet, SSH or VNC connections."
arch=('i686' 'x86_64') # untested on i686; please let me know if it works
url="https://github.com/arnestig/quickrdp"
license=('GPL3')
depends=('wxgtk' 'curl')
optdepends=('rdesktop: remote desktop support')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/arnestig/quickrdp/archive/$pkgver.tar.gz")
-md5sums=('e9d7c6863c2081f0a4dab43712a6fccb')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/arnestig/quickrdp/archive/$pkgver.tar.gz"
+ 'gcc6-fix.patch')
+md5sums=('e9d7c6863c2081f0a4dab43712a6fccb'
+ 'acdd61e400a0f089ebe08ad8ae29580b')
+
+prepare() {
+ cd "$srcdir"/$pkgname-$pkgver
+ patch -Np1 -i "$srcdir"/gcc6-fix.patch
+}
build() {
cd "$srcdir"/$pkgname-$pkgver
+
+ CFLAGS="-march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong"
+ CXXFLAGS="-march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong"
make
}
diff --git a/gcc6-fix.patch b/gcc6-fix.patch
new file mode 100644
index 000000000000..65fcd542271a
--- /dev/null
+++ b/gcc6-fix.patch
@@ -0,0 +1,31 @@
+From 675c94accde7fd2981aca8a7cc51b3403d994949 Mon Sep 17 00:00:00 2001
+From: Tobias Eliasson <arnestig@gmail.com>
+Date: Mon, 24 Oct 2016 20:56:42 +0200
+Subject: [PATCH] - Fixed compiler issues with gcc6. Solves issue #2
+
+---
+ src/RDPDatabase.h | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/RDPDatabase.h b/src/RDPDatabase.h
+index 232b662..dc8b1cf 100644
+--- a/src/RDPDatabase.h
++++ b/src/RDPDatabase.h
+@@ -36,7 +36,7 @@ namespace ConnectionType
+ VNC
+ };
+
+- inline wxString getConnectionTypeName( ConnectionType::ConnectionType connectionType )
++ inline wxString getConnectionTypeName( ConnectionType connectionType )
+ {
+ switch ( connectionType )
+ {
+@@ -55,7 +55,7 @@ namespace ConnectionType
+ }
+ }
+
+- inline ConnectionType::ConnectionType getConnectionTypeForPort( int port )
++ inline ConnectionType getConnectionTypeForPort( int port )
+ {
+ switch ( port )
+ {