summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..18f128668184
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = quvi
+ pkgdesc = Command-line tool for parsing video download links.
+ pkgver = 0.9.5
+ pkgrel = 1
+ url = http://quvi.sourceforge.net/
+ arch = x86_64
+ license = AGPL3
+ depends = libquvi
+ depends = libxml2
+ depends = json-glib
+ source = http://downloads.sourceforge.net/sourceforge/quvi/quvi-0.9.5.tar.xz
+ source = http://downloads.sourceforge.net/sourceforge/quvi/quvi-0.9.5.tar.xz.sig
+ validpgpkeys = E220FCFF9EADBA326FD6B23BBF1D59CCAD00BE50
+ md5sums = baa1d7b25e9fd173e952e27d4aa4b933
+ md5sums = SKIP
+
+pkgname = quvi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..77eea960ccf1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# $Id: PKGBUILD 266875 2017-11-15 14:29:11Z foutrelis $
+# Maintainer: Lukas Fleischer <lfleischer@archlinux.org>
+# Contributor: joyfulgirl@archlinux.us
+
+pkgname=quvi
+pkgver=0.9.5
+pkgrel=1
+pkgdesc='Command-line tool for parsing video download links.'
+arch=('x86_64')
+url='http://quvi.sourceforge.net/'
+license=('AGPL3')
+depends=('libquvi' 'libxml2' 'json-glib')
+source=("http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}-${pkgver}.tar.xz"{,.sig})
+md5sums=('baa1d7b25e9fd173e952e27d4aa4b933'
+ 'SKIP')
+validpgpkeys=('E220FCFF9EADBA326FD6B23BBF1D59CCAD00BE50') # Toni Gundogdu
+
+build() {
+ cd "${pkgname}-${pkgver}"
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}