summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD68
3 files changed, 58 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 88e8ade32b84..ca8e4d50dc2f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,39 +1,40 @@
pkgbase = qv2ray-v3
pkgdesc = A cross platform connection manager for V2Ray and other backends.
pkgver = 3.0.0rc1
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/Shadowsocks-NET/Qv2ray
arch = x86_64
license = GPL3
makedepends = cmake
- makedepends = gcc
makedepends = git
makedepends = grpc-cli
- makedepends = make
makedepends = ninja
makedepends = qt6-declarative
makedepends = qt6-tools
- makedepends = which
depends = grpc
depends = hicolor-icon-theme
depends = qt6-svg
optdepends = qt6-wayland: Wayland support (experimental)
optdepends = v2ray: Default V2Ray core
provides = qv2ray
+ provides = libqv2ray
+ provides = qv2ray-plugin-interface
conflicts = qv2ray
+ conflicts = libqv2ray
+ conflicts = qv2ray-plugin-interface
+ source = libqv2ray-f1adda6cc8c3370929aae86399731a5fad981346.zip::https://github.com/Shadowsocks-NET/Qv2rayBase/archive/f1adda6cc8c3370929aae86399731a5fad981346.zip
+ source = plugin-56197d32330df1ea47d846e574a2a9a0ec1df6ab.zip::https://github.com/Shadowsocks-NET/Qv2rayBase-PluginInterface/archive/56197d32330df1ea47d846e574a2a9a0ec1df6ab.zip
source = qv2ray-v3::git+https://github.com/Shadowsocks-NET/Qv2ray.git#tag=v3.0.0-rc1
source = git+https://github.com/itay-grudev/SingleApplication.git
source = git+https://github.com/cpeditor/QCodeEditor.git
source = git+https://github.com/danielsanfr/qt-qrcode.git
- source = git+https://github.com/Shadowsocks-NET/Qv2rayBase.git
source = git+https://github.com/xiaokangwang/v2ray-core-1.git
source = git+https://github.com/moodyhunter/libRoutingA.git
source = git+https://github.com/fukuchi/libqrencode.git
- source = git+https://github.com/libuv/libuv.git
- source = git+https://github.com/skypjack/uvw.git
- source = git+https://github.com/Shadowsocks-NET/Qv2rayBase-PluginInterface.git
- sha512sums = SKIP
- sha512sums = SKIP
+ source = git+https://github.com/libuv/libuv.git#commit=04289fa326b790c1a4abb236d1f9d913bacfc8c6
+ source = git+https://github.com/skypjack/uvw.git#commit=97c02c4f572179c4b31656d54bf78b5ab8b05f81
+ sha512sums = 2670d8579eeb48979740a20d56a67adb310d483bf23a63d63ac5f3a38605d172e74e0b7215203ad54f54f765ebfb694fd03b0d0b7aaa21ab5927b930cb7e426c
+ sha512sums = 504fcddd0d21273c427a4d5f092652031c85f96653ca749e8146fefd087911e71bb2d452cedceea9b4f4b557326f88d5a2c877c99fc0f5d844b6951d5388a9ad
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
diff --git a/.gitignore b/.gitignore
index 0ef9fd001eea..d6b0863f9ead 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
*/
*.tar*
-*.log \ No newline at end of file
+*.log
+*.zip \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 2bd535b572af..bcd12125bdf3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,40 @@
# Maintainer: Sam L. Yes <samlukeyes123 at gmail dot com>
# Contributor: database64128 <free122448@hotmail.com>
pkgname=qv2ray-v3
+_base_commit=f1adda6cc8c3370929aae86399731a5fad981346
+_libuv_commit=04289fa326b790c1a4abb236d1f9d913bacfc8c6
+_uvw_commit=97c02c4f572179c4b31656d54bf78b5ab8b05f81
+_plugin_commit=56197d32330df1ea47d846e574a2a9a0ec1df6ab
_tag=v3.0.0-rc1
pkgver=3.0.0rc1
-pkgrel=4
+pkgrel=5
pkgdesc="A cross platform connection manager for V2Ray and other backends."
arch=(x86_64)
url="https://github.com/Shadowsocks-NET/Qv2ray"
license=('GPL3')
depends=('grpc' 'hicolor-icon-theme' 'qt6-svg')
-makedepends=('cmake' 'gcc' 'git' 'grpc-cli' 'make' 'ninja' 'qt6-declarative' 'qt6-tools' 'which')
+makedepends=('cmake' 'git' 'grpc-cli' 'ninja' 'qt6-declarative' 'qt6-tools')
optdepends=(
'qt6-wayland: Wayland support (experimental)'
'v2ray: Default V2Ray core'
)
-provides=('qv2ray')
-conflicts=('qv2ray')
+provides=('qv2ray' 'libqv2ray' 'qv2ray-plugin-interface')
+conflicts=('qv2ray' 'libqv2ray' 'qv2ray-plugin-interface')
source=(
+ "libqv2ray-$_base_commit.zip::https://github.com/Shadowsocks-NET/Qv2rayBase/archive/$_base_commit.zip"
+ "plugin-$_plugin_commit.zip::https://github.com/Shadowsocks-NET/Qv2rayBase-PluginInterface/archive/$_plugin_commit.zip"
"$pkgname::git+$url.git#tag=$_tag"
"git+https://github.com/itay-grudev/SingleApplication.git"
"git+https://github.com/cpeditor/QCodeEditor.git"
"git+https://github.com/danielsanfr/qt-qrcode.git"
- "git+https://github.com/Shadowsocks-NET/Qv2rayBase.git"
"git+https://github.com/xiaokangwang/v2ray-core-1.git"
"git+https://github.com/moodyhunter/libRoutingA.git"
"git+https://github.com/fukuchi/libqrencode.git"
- "git+https://github.com/libuv/libuv.git"
- "git+https://github.com/skypjack/uvw.git"
- "git+https://github.com/Shadowsocks-NET/Qv2rayBase-PluginInterface.git"
+ "git+https://github.com/libuv/libuv.git#commit=$_libuv_commit"
+ "git+https://github.com/skypjack/uvw.git#commit=$_uvw_commit"
)
-sha512sums=('SKIP'
- 'SKIP'
+sha512sums=('2670d8579eeb48979740a20d56a67adb310d483bf23a63d63ac5f3a38605d172e74e0b7215203ad54f54f765ebfb694fd03b0d0b7aaa21ab5927b930cb7e426c'
+ '504fcddd0d21273c427a4d5f092652031c85f96653ca749e8146fefd087911e71bb2d452cedceea9b4f4b557326f88d5a2c877c99fc0f5d844b6951d5388a9ad'
'SKIP'
'SKIP'
'SKIP'
@@ -43,33 +47,51 @@ sha512sums=('SKIP'
patch_gitmodules() {
sed -i "s|https://github.com/.*/|${srcdir}/|;s|.git||" .gitmodules
- git submodule update --init --force --remote
}
prepare() {
- cd "$srcdir/$pkgname"
- patch_gitmodules
- cd "3rdparty/qt-qrcode"
+ cd $srcdir/$pkgname
patch_gitmodules
- cd "../../src/Qv2rayBase"
+ git submodule update --init \
+ 3rdparty/SingleApplication \
+ 3rdparty/QCodeEditor \
+ 3rdparty/qt-qrcode \
+ src/plugins/v2ray/3rdparty/v2ray-core \
+ src/plugins/routingA/core
+
+ _base_dir=src/Qv2rayBase
+ rmdir $_base_dir
+ ln -s ${srcdir}/Qv2rayBase-$_base_commit $_base_dir
+ cd $_base_dir/3rdparty
+ rmdir libuv uvw
+ ln -s ${srcdir}/libuv .
+ ln -s ${srcdir}/uvw .
+ cd ../src
+ rmdir PluginInterface
+ ln -s ${srcdir}/Qv2rayBase-PluginInterface-$_plugin_commit PluginInterface
+
+ cd $srcdir/$pkgname/3rdparty/qt-qrcode
patch_gitmodules
+ git submodule update --init
}
build() {
cd "$srcdir/$pkgname"
- export _QV2RAY_BUILD_INFO_="$pkgname AUR package"
- export _QV2RAY_BUILD_EXTRA_INFO_="r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
mkdir -p build && cd build
- cmake .. -GNinja \
- -DCMAKE_INSTALL_PREFIX=${pkgdir}/usr \
+ cmake .. \
+ -DBUILD_TESTING=OFF \
-DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=${pkgdir}/usr \
+ -DQV2RAY_BUILD_INFO="$pkgname AUR package" \
+ -DQV2RAY_BUILD_EXTRA_INFO="r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)" \
-DQV2RAY_DEFAULT_VASSETS_PATH="/usr/share/v2ray" \
-DQV2RAY_DEFAULT_VCORE_PATH="/usr/bin/v2ray" \
- -DQV2RAY_DISABLE_AUTO_UPDATE=on
- ninja
+ -DQV2RAY_AUTO_UPDATE=OFF \
+ -GNinja
+ cmake --build . --parallel
}
package() {
- cd "$srcdir/$pkgname"
- ninja -C "build" install
+ cd "$srcdir/$pkgname/build"
+ cmake --install .
}