summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--0001-feat-Remove-unbreakable-spaces-from-the-layouts.patch36
-rw-r--r--0001-only-generate-xorg-symbols.patch30
-rw-r--r--0002-feat-Generate-symbol-files-locally-and-exit.patch32
-rw-r--r--PKGBUILD19
5 files changed, 87 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e1ad64490045..0052613ff195 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = qwerty-lafayette
pkgdesc = QWERTY keyboard layout for francophone developers
- pkgver = 0.6.1
- pkgrel = 3
+ pkgver = 0.8.1
+ pkgrel = 1
url = https://qwerty-lafayette.org/
arch = any
license = WTFPL
makedepends = python
depends = xorg-server
- source = https://qwerty-lafayette.org/releases/lafayette_linux_v0.6.1.py
- source = 0001-only-generate-xorg-symbols.patch
- sha256sums = ec89492c1ed4ce2af0b545992bf408aa2cbf29d45ba7af7ea9ef96c3914693bb
- sha256sums = eec99e7ee9621a3d9934c8c4753741c23e187888bd60c16d6a7f08475d725248
+ source = https://qwerty-lafayette.org/releases/lafayette_linux_v0.8.1.py
+ source = 0001-feat-Remove-unbreakable-spaces-from-the-layouts.patch
+ source = 0002-feat-Generate-symbol-files-locally-and-exit.patch
+ sha256sums = cb39b8ccc66be995a747d7fc8443ca7a131a6890380854504210f5a6274d311f
+ sha256sums = 6a638f02808a6eb40510e245ff30bb090d8a5f0af348a8de5dc5cb1c5084d3dd
+ sha256sums = 7457a1faa275ce66f33626bcfe0d00f2e1cc0ab0e7153b2348419e9e582e620a
pkgname = qwerty-lafayette
-
diff --git a/0001-feat-Remove-unbreakable-spaces-from-the-layouts.patch b/0001-feat-Remove-unbreakable-spaces-from-the-layouts.patch
new file mode 100644
index 000000000000..e89418e57ba6
--- /dev/null
+++ b/0001-feat-Remove-unbreakable-spaces-from-the-layouts.patch
@@ -0,0 +1,36 @@
+From 26f516191d6f0ae1c80d74fdf89d6b5faa773253 Mon Sep 17 00:00:00 2001
+From: Frank LENORMAND <lenormf@gmail.com>
+Date: Thu, 2 Mar 2023 07:54:44 +0100
+Subject: [PATCH 1/2] feat: Remove unbreakable spaces from the layouts
+
+Varieties of whitespace characters are too easily inserted into code/writings,
+which creates errors that can be hard to identify.
+---
+ lafayette_linux_v0.8.1.py | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/lafayette_linux_v0.8.1.py b/lafayette_linux_v0.8.1.py
+index 6c4077f..fe16a84 100644
+--- a/lafayette_linux_v0.8.1.py
++++ b/lafayette_linux_v0.8.1.py
+@@ -434,7 +434,7 @@ LAYOUTS = [{
+ key <LSGT> {[ less , greater , lessthanequal , greaterthanequal, VoidSymbol , VoidSymbol , VoidSymbol , VoidSymbol ]}; // < > ≤ ≥
+
+ // Space bar
+- key <SPCE> {[ space , U202F , U2019 , U2019 , space , nobreakspace , VoidSymbol , VoidSymbol ]}; //   ’ ’
++ key <SPCE> {[ space , space , U2019 , U2019 , space , space , VoidSymbol , VoidSymbol ]}; //   ’ ’
+
+ // The “OneDeadKey” is an ISO_Level3_Latch, i.e. a “dead AltGr” key:
+ // this is the only way to have a multi-purpose dead key with XKB.
+@@ -558,7 +558,7 @@ LAYOUTS = [{
+ key <LSGT> {[ less , greater , VoidSymbol , VoidSymbol , VoidSymbol , VoidSymbol , VoidSymbol , VoidSymbol ]}; // < >
+
+ // Space bar
+- key <SPCE> {[ space , U202F , U2019 , U2019 , space , nobreakspace , VoidSymbol , VoidSymbol ]}; //   ’ ’
++ key <SPCE> {[ space , space , U2019 , U2019 , space , space , VoidSymbol , VoidSymbol ]}; //   ’ ’
+
+ // The “OneDeadKey” is an ISO_Level3_Latch, i.e. a “dead AltGr” key:
+ // this is the only way to have a multi-purpose dead key with XKB.
+--
+2.39.0
+
diff --git a/0001-only-generate-xorg-symbols.patch b/0001-only-generate-xorg-symbols.patch
deleted file mode 100644
index 608e78a71060..000000000000
--- a/0001-only-generate-xorg-symbols.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From a8daa589349bf00767723a406bc988b2c17d8588 Mon Sep 17 00:00:00 2001
-From: Frank LENORMAND <lenormf@gmail.com>
-Date: Mon, 29 Oct 2018 14:52:59 +0300
-Subject: [PATCH] patch
-
----
- lafayette_linux_v0.6.1.py | 7 +++++++
- 1 file changed, 7 insertions(+)
-
-diff --git a/lafayette_linux_v0.6.1.py b/lafayette_linux_v0.6.1.py
-index 9764d69..280083e 100644
---- a/lafayette_linux_v0.6.1.py
-+++ b/lafayette_linux_v0.6.1.py
-@@ -247,6 +247,13 @@ LAYOUTS = {'fr': [{
- };""")
- }]}
-
-+for locale, layouts in LAYOUTS.items():
-+ for layout in layouts:
-+ with open("%s_%s" % (locale, layout["name"]), "w") as fout:
-+ fout.write(layout["symbols"])
-+
-+import sys
-+sys.exit(0)
-
- ###############################################################################
- # XKB/symbols: append new layouts
---
-2.19.0
-
diff --git a/0002-feat-Generate-symbol-files-locally-and-exit.patch b/0002-feat-Generate-symbol-files-locally-and-exit.patch
new file mode 100644
index 000000000000..66c17a9606d3
--- /dev/null
+++ b/0002-feat-Generate-symbol-files-locally-and-exit.patch
@@ -0,0 +1,32 @@
+From db34f751d57ff0f5f87c633ac2420d2b998c11f8 Mon Sep 17 00:00:00 2001
+From: Frank LENORMAND <lenormf@gmail.com>
+Date: Thu, 2 Mar 2023 07:57:12 +0100
+Subject: [PATCH 2/2] feat: Generate symbol files locally and exit
+
+---
+ lafayette_linux_v0.8.1.py | 9 +++++++++
+ 1 file changed, 9 insertions(+)
+
+diff --git a/lafayette_linux_v0.8.1.py b/lafayette_linux_v0.8.1.py
+index fe16a84..f75d21b 100644
+--- a/lafayette_linux_v0.8.1.py
++++ b/lafayette_linux_v0.8.1.py
+@@ -567,6 +567,15 @@ LAYOUTS = [{
+ };""")
+ }]
+
++for layout in LAYOUTS:
++ meta, symbols = layout["meta"], layout["symbols"]
++ filename = "%s_%s" % (meta["locale"], meta["variant"])
++ with open(filename, "w") as fout:
++ fout.write(symbols)
++
++import sys
++sys.exit(0)
++
+ def layout_items():
+ layouts = {}
+ for name, desc in xkb.list_all(f"{LOCALE}/*").items():
+--
+2.39.0
+
diff --git a/PKGBUILD b/PKGBUILD
index 05fc1fe6cc38..12e80bb8e212 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,32 @@
# Creator: Frank LENORMAND <lenormf@gmail.com>
pkgname=qwerty-lafayette
-pkgver=0.6.1
-pkgrel=3
+pkgver=0.8.1
+pkgrel=1
pkgdesc="QWERTY keyboard layout for francophone developers"
arch=("any")
url="https://qwerty-lafayette.org/"
-license=('WTFPL')
+license=("WTFPL")
depends=("xorg-server")
makedepends=("python")
source=(
"https://qwerty-lafayette.org/releases/lafayette_linux_v${pkgver}.py"
- "0001-only-generate-xorg-symbols.patch"
+ "0001-feat-Remove-unbreakable-spaces-from-the-layouts.patch"
+ "0002-feat-Generate-symbol-files-locally-and-exit.patch"
)
sha256sums=(
- ec89492c1ed4ce2af0b545992bf408aa2cbf29d45ba7af7ea9ef96c3914693bb
- eec99e7ee9621a3d9934c8c4753741c23e187888bd60c16d6a7f08475d725248
+ cb39b8ccc66be995a747d7fc8443ca7a131a6890380854504210f5a6274d311f
+ 6a638f02808a6eb40510e245ff30bb090d8a5f0af348a8de5dc5cb1c5084d3dd
+ 7457a1faa275ce66f33626bcfe0d00f2e1cc0ab0e7153b2348419e9e582e620a
)
prepare() {
- patch --follow-symlinks -p1 < 0001-only-generate-xorg-symbols.patch
+ patch --follow-symlinks -p1 < 0001-feat-Remove-unbreakable-spaces-from-the-layouts.patch
+ patch --follow-symlinks -p1 < 0002-feat-Generate-symbol-files-locally-and-exit.patch
}
build() {
- mkdir build && cd build
+ mkdir -p build && cd build
python ../lafayette_linux_v"${pkgver}".py
}