summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--001-qwtconfig-arch.patch69
-rw-r--r--PKGBUILD13
2 files changed, 74 insertions, 8 deletions
diff --git a/001-qwtconfig-arch.patch b/001-qwtconfig-arch.patch
new file mode 100644
index 000000000000..ac1d537fa89f
--- /dev/null
+++ b/001-qwtconfig-arch.patch
@@ -0,0 +1,69 @@
+Index: qwtconfig.pri
+===================================================================
+--- qwtconfig.pri (Revision 3381)
++++ qwtconfig.pri (Arbeitskopie)
+@@ -19,7 +19,7 @@
+ QWT_INSTALL_PREFIX = $$[QT_INSTALL_PREFIX]
+
+ unix {
+- QWT_INSTALL_PREFIX = /usr/local/qwt-$$QWT_VERSION-svn
++ QWT_INSTALL_PREFIX = /usr
+ # QWT_INSTALL_PREFIX = /usr/local/qwt-$$QWT_VERSION-svn-qt-$$QT_VERSION
+ }
+
+@@ -28,8 +28,8 @@
+ # QWT_INSTALL_PREFIX = C:/Qwt-$$QWT_VERSION-svn-qt-$$QT_VERSION
+ }
+
+-QWT_INSTALL_DOCS = $${QWT_INSTALL_PREFIX}/doc
+-QWT_INSTALL_HEADERS = $${QWT_INSTALL_PREFIX}/include
++QWT_INSTALL_DOCS = $${QWT_INSTALL_PREFIX}/share/doc/qwt-qt$${QT_MAJOR_VERSION}
++QWT_INSTALL_HEADERS = $${QWT_INSTALL_PREFIX}/include/qwt-qt$${QT_MAJOR_VERSION}
+ QWT_INSTALL_LIBS = $${QWT_INSTALL_PREFIX}/lib
+
+ ######################################################################
+@@ -42,7 +42,7 @@
+ # runtime environment of designer/creator.
+ ######################################################################
+
+-QWT_INSTALL_PLUGINS = $${QWT_INSTALL_PREFIX}/plugins/designer
++QWT_INSTALL_PLUGINS = $${QWT_INSTALL_PREFIX}/lib/qt$${QT_MAJOR_VERSION}/plugins/designer
+
+ # linux distributors often organize the Qt installation
+ # their way and QT_INSTALL_PREFIX doesn't offer a good
+@@ -63,7 +63,7 @@
+ # with every Qt upgrade.
+ ######################################################################
+
+-QWT_INSTALL_FEATURES = $${QWT_INSTALL_PREFIX}/features
++QWT_INSTALL_FEATURES = $${QWT_INSTALL_PREFIX}/lib/qt$${QT_MAJOR_VERSION}/mkspecs/features
+ # QWT_INSTALL_FEATURES = $$[QT_INSTALL_PREFIX]/features
+
+ ######################################################################
+@@ -137,7 +137,7 @@
+ # Otherwise you have to build them from the examples directory.
+ ######################################################################
+
+-QWT_CONFIG += QwtExamples
++# QWT_CONFIG += QwtExamples
+
+ ######################################################################
+ # The playground is primarily intended for the Qwt development
+@@ -148,7 +148,7 @@
+ # Otherwise you have to build them from the playground directory.
+ ######################################################################
+
+-QWT_CONFIG += QwtPlayground
++# QWT_CONFIG += QwtPlayground
+
+ ######################################################################
+ # If you want to auto build the tests, enable the line below
+@@ -155,7 +155,7 @@
+ # Otherwise you have to build them from the tests directory.
+ ######################################################################
+
+-QWT_CONFIG += QwtTests
++# QWT_CONFIG += QwtTests
+
+ ######################################################################
+ # When Qt has been built as framework qmake wants
diff --git a/PKGBUILD b/PKGBUILD
index dbbb34638ea0..96ad7725c344 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,17 +14,15 @@ sha512sums=('SKIP')
prepare() {
cd qwt-6.2
- sed -e '/^\s*QWT_INSTALL_PREFIX/ s|=.*|= /usr|' \
- -e '/^QWT_INSTALL_DOCS/ s|/doc|/share/doc/qwt|' \
- -e '/^QWT_INSTALL_HEADERS/ s|include|&/qwt|' \
- -e '/^QWT_INSTALL_PLUGINS/ s|plugins/designer|lib/qt/&|' \
- -e '/^QWT_INSTALL_FEATURES/ s|features|lib/qt/mkspecs/&|' \
- -i qwtconfig.pri
+ patch --forward -p1 -i ${srcdir}/../001-qwtconfig-arch.patch
+ sed -e '/^TARGET/ s|(qwt)|(qwt-qt$${QT_MAJOR_VERSION})|' \
+ -e '/^\s*QWT_SONAME/ s|libqwt|&-qt$${QT_MAJOR_VERSION}|' \
+ -i src/src.pro
}
build() {
cd qwt-6.2
- qmake-qt6 qwt.pro
+ qmake6 qwt.pro
make
}
@@ -32,6 +30,5 @@ package() {
cd qwt-6.2
make INSTALL_ROOT="${pkgdir}" install
- mv "${pkgdir}/usr/share/doc/qwt/man" "${pkgdir}/usr/share"
install -Dm 644 COPYING -t "${pkgdir}/usr/share/licenses/${pkgname}"
}