summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD24
2 files changed, 17 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 968078d04a1d..9720b4ff6681 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = r-psea
- pkgdesc = Population-Specific Expression Analysis.
+ pkgdesc = Population-Specific Expression Analysis
pkgver = 1.36.0
- pkgrel = 1
+ pkgrel = 2
url = https://bioconductor.org/packages/PSEA
arch = any
- license = Artistic2.0
- depends = r
+ license = Artistic-2.0
depends = r-biobase
optdepends = r-biocstyle
source = https://bioconductor.org/packages/release/bioc/src/contrib/PSEA_1.36.0.tar.gz
- sha256sums = 5ee830e1b1f6b11afa00ee2394405c0a79d4ae69d3124fe622e7ff6b99eaf609
+ md5sums = c8f9f8210c265d722d76668e19a6fd7c
+ b2sums = 388de01f9286438d7fc5c35d1855768a6f90ce59734de754e5be3b6877c830e61a5cdf73d3f5167db30e9111f09bccb564fca4643aa51393f93cb75d55f3462b
pkgname = r-psea
diff --git a/PKGBUILD b/PKGBUILD
index 50d17d90baff..11eead555abc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,28 +3,28 @@
_pkgname=PSEA
_pkgver=1.36.0
pkgname=r-${_pkgname,,}
-pkgver=1.36.0
-pkgrel=1
-pkgdesc='Population-Specific Expression Analysis.'
-arch=('any')
-url="https://bioconductor.org/packages/${_pkgname}"
-license=('Artistic2.0')
+pkgver=${_pkgver//-/.}
+pkgrel=2
+pkgdesc="Population-Specific Expression Analysis"
+arch=(any)
+url="https://bioconductor.org/packages/$_pkgname"
+license=('Artistic-2.0')
depends=(
- r
r-biobase
)
optdepends=(
r-biocstyle
)
source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-sha256sums=('5ee830e1b1f6b11afa00ee2394405c0a79d4ae69d3124fe622e7ff6b99eaf609')
+md5sums=('c8f9f8210c265d722d76668e19a6fd7c')
+b2sums=('388de01f9286438d7fc5c35d1855768a6f90ce59734de754e5be3b6877c830e61a5cdf73d3f5167db30e9111f09bccb564fca4643aa51393f93cb75d55f3462b')
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
}
-# vim:set ts=2 sw=2 et: