summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD26
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..227195280831
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = r-rsvgtipsdevice
+ pkgdesc = An R SVG Graphics Device with Dynamic Tips and Hyperlinks
+ pkgver = 1.0.7
+ pkgrel = 4
+ url = https://cran.r-project.org/package=RSVGTipsDevice
+ arch = any
+ license = GPL
+ depends = r
+ source = https://github.com/cran/RSVGTipsDevice/archive/refs/tags/1.0-7.tar.gz
+ sha256sums = 7a32f363b53289da992b4660031c008231b3990e1789cdc85ab47f3c786d1c54
+
+pkgname = r-rsvgtipsdevice
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7a1d973468a8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=RSVGTipsDevice
+_pkgver=1.0-7
+pkgname=r-${_pkgname,,}
+pkgver=1.0.7
+pkgrel=4
+pkgdesc='An R SVG Graphics Device with Dynamic Tips and Hyperlinks'
+arch=('any')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('GPL')
+depends=(
+ r
+)
+source=("https://github.com/cran/${_pkgname}/archive/refs/tags/${_pkgver}.tar.gz")
+sha256sums=('7a32f363b53289da992b4660031c008231b3990e1789cdc85ab47f3c786d1c54')
+
+build() {
+ R CMD INSTALL ${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: