summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD42
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..68c22c9df604
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = r-stanova
+ pkgdesc = Bayesian Models with Categorical Variables
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/bayesstuff/stanova
+ arch = x86_64
+ license = LGPL3
+ makedepends = git
+ depends = r
+ depends = r-lme4
+ depends = r-coda
+ depends = r-rstan
+ depends = r-emmeans
+ optdepends = r-testthat
+ optdepends = r-rstanarm
+ optdepends = r-brms
+ optdepends = r-memss
+ optdepends = r-afex
+ optdepends = r-glmmtmb
+ optdepends = r-bayesplot
+ optdepends = r-tibble
+ optdepends = r-tidybayes
+ optdepends = r-tidyverse
+ source = git+https://github.com/bayesstuff/stanova.git
+ sha256sums = SKIP
+
+pkgname = r-stanova
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f4cfdf3a7fcf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+#Maintainer: sukanka <su975853527 AT gmail.com>
+_pkgname=stanova
+_pkgver=0.3-0
+pkgname=r-${_pkgname,,}
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="Bayesian Models with Categorical Variables"
+arch=('x86_64')
+url="https://github.com/bayesstuff/${_pkgname}"
+license=('LGPL3')
+depends=(r
+ r-lme4
+ r-coda
+ r-rstan
+ r-emmeans
+)
+makedepends=(git)
+optdepends=(
+ r-testthat
+ r-rstanarm
+ r-brms
+ r-memss
+ r-afex
+ r-glmmtmb
+ r-bayesplot
+ r-tibble
+ r-tidybayes
+ r-tidyverse
+)
+source=("git+https://github.com/bayesstuff/${_pkgname}.git")
+sha256sums=('SKIP')
+
+
+build() {
+ mkdir -p ${srcdir}/usr/lib/R/library
+ R -e "install.packages('${srcdir}/${_pkgname}',\
+ type='source', repos=NULL,lib='${srcdir}/usr/lib/R/library', INSTALL_opts='--no-multiarch --no-docs --no-test-load')"
+}
+
+package() {
+ cp -a --no-preserve=ownership "${srcdir}/usr" "${pkgdir}"
+}