summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD25
2 files changed, 19 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8e8a22a0ebae..2d3a24117e1a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = r-timeomics
pkgdesc = Time-Course Multi-Omics data integration
- pkgver = 1.14.0
+ pkgver = 1.16.0
pkgrel = 1
url = https://bioconductor.org/packages/timeOmics
arch = any
- license = GPL
- depends = r
+ license = GPL-3.0-only
+ depends = r-checkmate
depends = r-dplyr
depends = r-ggplot2
depends = r-ggrepel
@@ -25,7 +25,8 @@ pkgbase = r-timeomics
optdepends = r-snow
optdepends = r-testthat
optdepends = r-tidyverse
- source = https://bioconductor.org/packages/release/bioc/src/contrib/timeOmics_1.14.0.tar.gz
- sha256sums = c518ac5fc3b979f652b9eda376f00dbbf716a764a20cdb6dbf76699337a8a887
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/timeOmics_1.16.0.tar.gz
+ md5sums = ba8315de54ba6b48d8f3a6bb1c3c1487
+ b2sums = b8165d9cff2db57b77cf7c333c116cb5967484dac8e54e1aff133450fd18dbb3c37850d18f4334f5c48457fc76f1b503588a3f5d8fd2ef57cfc6db07c51ec0f7
pkgname = r-timeomics
diff --git a/PKGBUILD b/PKGBUILD
index 00e29a355dfa..526e620b8f4e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
_pkgname=timeOmics
-_pkgver=1.14.0
+_pkgver=1.16.0
pkgname=r-${_pkgname,,}
-pkgver=1.14.0
+pkgver=${_pkgver//-/.}
pkgrel=1
-pkgdesc='Time-Course Multi-Omics data integration'
-arch=('any')
-url="https://bioconductor.org/packages/${_pkgname}"
-license=('GPL')
+pkgdesc="Time-Course Multi-Omics data integration"
+arch=(any)
+url="https://bioconductor.org/packages/$_pkgname"
+license=('GPL-3.0-only')
depends=(
- r
+ r-checkmate
r-dplyr
r-ggplot2
r-ggrepel
@@ -34,14 +34,15 @@ optdepends=(
r-tidyverse
)
source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-sha256sums=('c518ac5fc3b979f652b9eda376f00dbbf716a764a20cdb6dbf76699337a8a887')
+md5sums=('ba8315de54ba6b48d8f3a6bb1c3c1487')
+b2sums=('b8165d9cff2db57b77cf7c333c116cb5967484dac8e54e1aff133450fd18dbb3c37850d18f4334f5c48457fc76f1b503588a3f5d8fd2ef57cfc6db07c51ec0f7')
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
}
-# vim:set ts=2 sw=2 et: