summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c260290ba021
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = r-txdb.hsapiens.ucsc.hg19.knowngene
+ pkgdesc = Annotation package for TxDb object(s)
+ pkgver = 3.2.2
+ pkgrel = 4
+ url = https://bioconductor.org/packages/TxDb.Hsapiens.UCSC.hg19.knownGene
+ arch = any
+ license = Artistic2.0
+ depends = r
+ depends = r-annotationdbi
+ depends = r-genomicfeatures
+ source = https://bioconductor.org/packages/release/data/annotation/src/contrib/TxDb.Hsapiens.UCSC.hg19.knownGene_3.2.2.tar.gz
+ sha256sums = 063de2b1174782a0b2b8ab7f04a0bdf3c43252cb67c685a9f8ef2b8e318352e9
+
+pkgname = r-txdb.hsapiens.ucsc.hg19.knowngene
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..db32997b4142
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=TxDb.Hsapiens.UCSC.hg19.knownGene
+_pkgver=3.2.2
+pkgname=r-${_pkgname,,}
+pkgver=3.2.2
+pkgrel=4
+pkgdesc='Annotation package for TxDb object(s)'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('Artistic2.0')
+depends=(
+ r
+ r-annotationdbi
+ r-genomicfeatures
+)
+source=("https://bioconductor.org/packages/release/data/annotation/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('063de2b1174782a0b2b8ab7f04a0bdf3c43252cb67c685a9f8ef2b8e318352e9')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: