summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e6f729c7e912
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = r-txdb.rnorvegicus.ucsc.rn4.ensgene
+ pkgdesc = Annotation package for TxDb object(s)
+ pkgver = 3.2.2
+ pkgrel = 4
+ url = https://bioconductor.org/packages/TxDb.Rnorvegicus.UCSC.rn4.ensGene
+ arch = any
+ license = Artistic2.0
+ depends = r
+ depends = r-annotationdbi
+ depends = r-genomicfeatures
+ source = https://bioconductor.org/packages/release/data/annotation/src/contrib/TxDb.Rnorvegicus.UCSC.rn4.ensGene_3.2.2.tar.gz
+ sha256sums = 15325d09a9da4292678768164e1850a78595dd96351970553844f5eeac5f683f
+
+pkgname = r-txdb.rnorvegicus.ucsc.rn4.ensgene
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..74cb90fe7782
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=TxDb.Rnorvegicus.UCSC.rn4.ensGene
+_pkgver=3.2.2
+pkgname=r-${_pkgname,,}
+pkgver=3.2.2
+pkgrel=4
+pkgdesc='Annotation package for TxDb object(s)'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('Artistic2.0')
+depends=(
+ r
+ r-annotationdbi
+ r-genomicfeatures
+)
+source=("https://bioconductor.org/packages/release/data/annotation/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('15325d09a9da4292678768164e1850a78595dd96351970553844f5eeac5f683f')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: