summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ee4a438b0b5b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = r8s
+ pkgdesc = Analysis of rates (r8s) of evolution
+ pkgver = 1.80
+ pkgrel = 2
+ url = http://loco.biosci.arizona.edu/r8s/
+ arch = i686
+ arch = x86_64
+ license = Public Domain
+ depends = gcc-libs
+ depends = gcc-fortran
+ source = http://loco.biosci.arizona.edu/r8s/r8s.dist.tgz
+ md5sums = ce39fde6778dfdf9f20442a573c685db
+
+pkgname = r8s
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9124ef2878b8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Author: Stunts <f.pinamartins@gmail.com>
+
+pkgname=r8s
+pkgver=1.80
+pkgrel=2
+pkgdesc="Analysis of rates ("r8s") of evolution"
+arch=(i686 x86_64)
+license=('Public Domain')
+depends=('gcc-libs' 'gcc-fortran')
+url="http://loco.biosci.arizona.edu/r8s/"
+source=(http://loco.biosci.arizona.edu/r8s/${pkgname}.dist.tgz)
+md5sums=('ce39fde6778dfdf9f20442a573c685db')
+
+build() {
+ cd "${srcdir}/dist"
+ make -f makefile
+}
+
+package() {
+ cd "${srcdir}/dist"
+ install -d ${pkgdir}/usr
+ install -d ${pkgdir}/usr/bin
+ install -D -m 755 r8s ${pkgdir}/usr/bin/
+}