summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
-rw-r--r--plugin.path.patch22
3 files changed, 27 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0d702d7eba6e..21a9895b7dfc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,8 +14,10 @@ pkgbase = radare2-bindings-git
depends = python2
source = radare2-bindings-git::git://github.com/radare/radare2-bindings.git
source = radare2-pipe-git::git+https://github.com/radare/radare2-r2pipe.git
+ source = plugin.path.patch
md5sums = SKIP
md5sums = SKIP
+ md5sums = 6274d65a2455632c6083697602039679
pkgname = radare2-bindings-git
provides = radare2-bindings
diff --git a/PKGBUILD b/PKGBUILD
index 62c2a5056bf8..af9caf44000c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,10 +12,11 @@ makedepends=('git' 'valabind' 'swig')
source=("${pkgname}::git://github.com/radare/radare2-bindings.git"
"radare2-pipe-git::git+https://github.com/radare/radare2-r2pipe.git"
+ "plugin.path.patch"
)
md5sums=('SKIP'
'SKIP'
- )
+ '6274d65a2455632c6083697602039679')
pkgver() {
@@ -25,6 +26,7 @@ pkgver() {
prepare() {
cd ${srcdir}/${basename}
+ git apply ${srcdir}/plugin.path.patch
}
build() {
diff --git a/plugin.path.patch b/plugin.path.patch
new file mode 100644
index 000000000000..a021ca58864c
--- /dev/null
+++ b/plugin.path.patch
@@ -0,0 +1,22 @@
+diff --git a/libr/lang/p/Makefile b/libr/lang/p/Makefile
+index fc2eae3..05d0eec 100644
+--- a/libr/lang/p/Makefile
++++ b/libr/lang/p/Makefile
+@@ -6,7 +6,7 @@ CFLAGS+=-DPREFIX=\"${PREFIX}\"
+
+ DUK_CFLAGS+=-Wall -DPREFIX=\"${PREFIX}\" -I. -Iduk
+
+-R2PM_PLUGDIR?=$(shell r2 -H R2_USER_PLUGINS)
++R2PM_PLUGDIR?=$(shell r2 -H R2_LIBR_PLUGINS)
+ EXT_SO?=$(shell r2 -H LIBEXT)
+
+ ifeq ($(EXT_SO),)
+@@ -130,7 +130,7 @@ mrproper clean:
+
+ #R2_PLUGIN_PATH=$(shell r2 -hh| grep PLUGINS|awk '{print $$2}')
+ #R2_PLUGIN_PATH=$(shell r2 -nqc 'e dir.plugins' -)
+-R2_PLUGIN_PATH=$(shell r2 -H R2_USER_PLUGINS)
++R2_PLUGIN_PATH=$(shell r2 -H R2_LIBR_PLUGINS)
+
+ install:
+ mkdir -p $(DESTDIR)/$(R2_PLUGIN_PATH)